Pots roundups 🛑

I have more than £100 on my main account…
Round up to savings pot is on…

Can you go into the settings of the pot you wish to round up to and ensure the toggle is set to on for Roundups?

If this is correct then im unsure what the problem could be

Definitely on…
Switched off and on again will check later )

I’m currently investigating some issues with the round up service. It was being a little slow this morning, but I think it should have caught up now—has your transaction been rounded up now?


Yes! :slight_smile: Thanks!

Excellent! Thanks for confirming :blush:

I made a purchase for £2.35 at 9:07 - that’s still not rounded up. Will wait and see what happens :wink:

If you want to DM me your email address, I can take a look :eyes:

Edit: looks like your round up just went through! :blush:

1 Like

Nevermind; looks like the round up service was being slow again :disappointed:

I’ve just deployed a fix, so hopefully it should catch up :crossed_fingers:

1 Like

All caught up!



Just confirming all is good here now too :smile: :+1:

If you don’t mind me asking, what typically causes backlogs like these?

I assume it’s the messaging queue? Is it latency issues?


In this case, the round up service was failing to create the deposit, because it had already created a deposit for the same transaction with a different deposit amount. We think that the round up service had re-tried the deposit (for whatever reason), which is usually safe (we won’t process a deposit twice for the same transaction). But the transaction amount had been updated in the meantime, so now when it calculated the round up, it came out with a different amount!

We hadn’t anticipated this happening, so when it got an error making the deposit, it would re-try… and also “backoff” the entire queue, slowing down the rate at which we were processing transactions.

The fix was to simply not retry making the deposit when it had already happened, so the queue doesn’t slow down at all.

Apologies for the overly-technical explanation, but you did ask :smile:


Nah, never apologise for that. Some of us love this stuff.


Super interesting insight, thank you!

No apology needed, it’s inherently technical. Thanks! :smiley:


As a software developer i love this level of insight, thanks Tim!


I made a purchase at 11:50 and it still hasn’t rounded up

Are you in your overdraft? There’s a help article somewhere explaining why your round ups might not be working

No, over 1k in the account

Please can you get in touch with support through the app? They can help easier than I can! :blush: