Pic and video failing to upload. few minutes. It's been 2 days

Message says, something went wrong but we don’t know what. Please try again in a few minutes. It’s been 2 days


Have you tried on both WiFi and mobile data?

Can you try uninstalling the app, restarting your phone and then reinstall the app from your app store (not from icloud backups if you have an iPhone)

If that doesn’t work I would do it on another phone and when you’ve uploaded the docs you can sign back in your phone.

Yes I’ve tried all of the above. I dont have an iPhone. I tried it on a different device also with no luck. One of the messages said, sorry were having a problem with our server right now.

I am in another country at the moment (but I am a British resident) im not sure if that is a problem?

Are you using a VPN or anything?

It may be stopping you as you’re abroad, will you be back anytime soon?

1 Like

If you are not using a VPN try using one.

I’d suggest trying this 1st , it’s not a fully fledged VPN but if may fix the issue you are seeing, it’s from Cloudflare, so it’s a reputable company.


Thank you. Im going to use a VPN and see if it works.

Thanks for your help

1 Like