Can't register in the app

I tried to record video with me many times and it’s always “red screen” with “sorry, no internet connection” after I click “Submit”. My internet is fine. My husband with the same internet provider was able to upload video instantly and with no problems at all.
Details to reproduce:
App not even trying to upload anything. Instant red screen.
Tried everything: WiFi, data (I have EE, as well as my husband). Doesn’t work. Maybe you can delete my “half-created” account on your side so I can start from clean slate? Husband created account with no problems at all. We both have iPhones, same providers, same everything.
I’ve tried three different devices - iPhone 11, iPhone 11 Pro, iPad
App Version:

You’ll need to contact and they’ll be able to help you out

I see that you’re on 4G. Your plan hasn’t ran out of data or anything has it?

The video you record will likely be quite large so perhaps it’s tipping you over your limit if you’re close to it? Have you tried when you’re connected to WIFI?

Looking at the screenshot, your phone appears to be on power-saver mode, which cuts down on internet traffic. Your battery icon should be white.

Go into settings, battery, turn off low power mode.

1 Like

Sound & camera can mess things up too - have a look at the checks here;

Thank you! Will do.

Thanks a lot for your help! Yes, I’ve tried t switch to the normal battery mode too. Same story.

Thanks a lot for trying help me. Sure, I’ve tried the WiFi

Can you tether to your partner’s phone and see if that works, using his internet?

Also have you tried deleting and reinstalling the app?

Thank you so much! Tried that one too. Still without success.
And sure I’ve tried to delete and re-install the app on my smartphone and two different devices.

Thank you so much for your help! But that definitely not a camera. I’ve tried three different devices without success

Really weird, hopefully the guys at Monzo can help.

1 Like

Hey guys,
Thanks to everyone, who tried to help! It is a very supportive community.
I’ve tried again yesterday with one more device and new location, and that works!

Waiting for my new card from Monzo :pray:



Thanks & good to know you have access now!

Strange how it didn’t work with the other devices, all in the other location?

Still, don’t have an explanation to that. Probably it’s guilty of the ЕЕ connection stability

1 Like