Need to change my phone to upgrade a/c


(Andy Hunt) #1

Hi , what are the minimum requirements on a mobile phone or tablet to upgrade to the new Monzo APP ?


(Peter Roberts) #2

Best to open a chat with the support in app :slightly_smiling_face:. They should be able to help you


(Andy Hunt) #3

OK Thanks, Peter


(Gareth) #4

From the respective app pages:

Compatibility
Requires iOS 9.0 or later. Compatible with iPhone, iPad and iPod touch.

See here about iOS/iPhone support

Requires Android
5.0 and up