✅ [monzo.me] Can't make payment

Issue: I have sent a monzo.me link to my colleagues. They have tried to send the money by entering in their bank details manually and then when they click the button to make the payment they are presented with a white screen and in the centre of the screen it says An unexpected error occurred.

My link: https://monzo.me/garethlowrie/53.40?d=Hotel%20and%20camping

Details to reproduce: Create a Monzo.me link like that of the one above.
OS: Latest Chrome on latest macOS.
Device: Macbook Pro
App Version: N/A

Screenshots:

Have you tried it without the message?

Not saying this is a solution but might help narrow down the cause?

Just tried this - same error.
Each time the form is submitted there is an Active Card Check on my card - in case this is of any help.

I’m also getting a white screen with a small error message.

Why doesnt Monzo inform their customers that there is a technical error or there are ongoing issues etc. It would be nice to know and then also when it’s fixed too. Not Good :frowning:

1 Like

This used to happen to me, both me requesting a payment, or using a monzo.me link that was sent to me…

I also found that retrying it, I got no confirmation that it went through, but ended up paying the guy twice… seems like an ongoing bug, not tried it recently though

1 Like

Erm. They do. Both within the app, and via monzo.statuspage.io.

Well they haven’t on this occasion !

Then perhaps it’s not a system-wide issue but something specific to a small subset. What did Monzo support say when you informed them?

I’ve just tried your link on Chrome on my Mac. All looked fine to me. (I haven’t sent you any money though!!)

Chrome is: Version 74.0.3729.169 (Official Build) (64-bit)

Very odd.

The error doesn’t occur until you click the Send Gareth XXXX buttton! (Don’t try it ha!)

I’ve reported this to the security team and they are looking into it :slight_smile: Sorry for the inconvenience, and thanks for raising!

4 Likes

Thanks for reporting this! We’ve identified the problem that was causing the page to error and should have a fix out very shortly :hammer_and_wrench:

7 Likes

We’ve rolled out the fix for this now :bug:- you might need to clear your browser cache to get the new version of the page - sorry for the trouble and thanks once again for letting us know!

3 Likes

Thanks Liam! #hotfixfridays

@liamn Just an update, works great for me now. Thanks