Monzo crashing on launch [Raised internally - investigating]

Thanks so much for all collating all those links, that was super helpful! :bowing_man:

I’ve just tried the steps you’ve mentioned (launch the Monzo app, background it, then force-restart the phone) and I’ve seen the crash once I rebooted and (tried to) launch the Monzo app.

I’ve pulled the logs, and this looks like a crash that we found the cause of a few weeks ago - we’ve included a temporary recovery mechanism in version 5.3.0: before that version, this would cause a repeating crash - you wouldn’t be able to open the app unless you deleted & reinstalled it. Since 5.3.0 we’ve stopped the repeating crash, and rather logged you out. It’s not ideal, but it’s better than the repeat crash and it allows you to get back into the app and your account while we get the actual fix sorted.

We think that we have a fix for this (so that it doesn’t even crash the first time, and doesn’t log you out,) but we’re still testing it out and making sure that it solves the problem. Your steps to reproduce this come in really handy here, since we didn’t have a way reliably create the crash, and hence confirm that the fix had in fact worked - now we can, thank you! We’re hoping to have the fix ready for second release in the new year.


Awesome, thank you! Looking forward to the fix in the new year! :partying_face:


Big up to @N26throwaway for your work here.


Hey folks! :wave: Just an update on this - the app version (5.7.0) with the fix for this starts rolling out to the AppStore today. This should have this specific crash sorted - I’ve tested it with @N26throwaway’s steps and saw the crash in the old build, but not with the latest version :tada:

Thank you all so much for the help getting this fixed :bowing_man:


Glad it’s fixed, thank you so much!

If we’re getting crashes etc after this, should we continue to report them in the same way etc? Or are your efforts switching elsewhere, and a different team picking this up?

Just wanting to raise that the app is borderline unusable with Trends/New Homepage in its current form, with it regularly crashing on me (iOS), and if they’ll be looked into with the same urgency as you did with this one? :frowning_face:


My suspicion is this is a separate issue related to what I suspect to be a memory leak of some sort.

I debated starting another thread for it whilst this one was still ongoing, but I do think that’s a separate issue.

It’s being discussed currently over here, where I’ve shared a known and tested temporary fix:

And thanks @leewatkins for getting this one fixed! :partying_face:

1 Like

We’ll be taking a look at a a few more things - more details here. (I think you’ve seen that already)

Please do share any details that you can with us, and if you’re able to share crash logs with that it would be super helpful. Instructions here: