Monzo App stuck on loading screen then exits

Issue: my monzo app won’t open, it shows the logo and just freezes then exits the app. All of my apps work apart from Monzo. I want to know if this has happened before?And yes I have deleted and reinstalled my phone numerous times. Any help would be appreciated

OS: IOS 17.3.1
Device: IPhone XS Max
App Version: 5.63.0


1 Like

Yes. A lot. It had been fixed though. I really hope it’s not back!


Away from my phone at the moment, but I’ll see if I can reproduce this later on.

Last time, deleting Monzo, restarting the phone, then reinstalling Monzo helped most (but not all) people most (but not always) most of the time.

Joining the TestFlight program and installing an older version of the app also worked.

But these were only ever temporary remedies. The bug kept coming back.

1 Like

If you head to iPhone settings, find Monzo, then at the bottom tap Reset Session, it should wipe the app data and then get you back in fresh :crossed_fingers:t3:


thank you!!! I’ll try now

It’s so annoying, I genuinely thought my phone was the issue but all my apps work it’s been going on for over a week now

1 Like

nothing seems to work​:sob::sob::sob:, I just tried it rn. Feels like it will never go away

I’ve tagged the iOS health team, so hopefully they’ll take a look to see what’s going on here.

Did you try installing an older version of the app from TestFlight?

Again, it’s prudent to delete Monzo from your phone first, then restart your phone, before installing an older build from TestFlight. It’s worth trying if the simple delete app, restart phone, reinstall app method didn’t work.

1 Like

Hey @33fourty, sorry to hear about this.
Could you please DM me the email address that you use on your account and I can take a look?


sure and thank you!

I clicked on your account, there’s no “message” button? Am I supposed to reach a certain level to be granted that? Bare in mind I just created the account today

1 Like

I see, I’m new to this tbh. So I should download the TestFlight build to see if it works?

1 Like

If you’re able to, yes please. That might give us some extra information to work with :pray:t2:


Yeah - it’s because you’re new. This community is run on the ‘Discourse’ forum platform, and Discourse operates Trust Levels. There are 5 trust levels with discourse, but this Community seems to operate only 4 levels: New/Basic, Member, Regular and Leader (Coral Crew)

You increase up the trust levels the more you read, post, like and be liked. Once you get to the ‘Member’ trust level, you can send PM’s to others.

The requirements to move up (or down!) the trust levels are here:

Oh, and welcome @33fourty ! :wave:


not sure what to do here?

1 Like

Since when was there an invite code for TestFlight? :face_with_raised_eyebrow:

I’m not sure what to suggest there, I’m sorry. It must be a new thing.

Edit: Oh, I see the issue! You’re tapping on redeem. Tap on the Monzo app icon instead and it’ll take you to their TestFlight page where you can install old and beta builds.

Given that it says “Open” and not “Install” you already have the 5.64.0 beta installed. Does the app launch now?


Has this issue been resolved yet? I’m suffering the same issue, startup screen hanging before crashing after about 10 seconds. I’m using latest Testflight version of Monzo app which appears to have just updated automatically before I got this issue about 20 mins ago.

I need to make an urgent transfer… please help! Trying to call CS on 08008021281 but going round in circles with the automated system. When you reach the option to select ‘cannot access app’ the following options are garbage with nothing related to select. Had to tell porkys to finally be put on hold… 20 mins later still waiting… :frowning:

iPhone XR
iOS 17.3.1
V 5.64.0


it’s still being resolved unfortunately, so it just shows the logo then exits for you? Maybe try to delete, restart your phone then install the app again. Appears to work for some people, not me though

1 Like

Yup, same issue like you said. I was using the TestFlight version and it had automatically updated to V 5.64.0 just before trying to open.

Issue now resolved while chatting with CS. Completely deleted the Monzo TestFlight app and data, did not restart phone, installed Monzo V 5.63.0 from app store. No further issues.

Hope you gets yours sorted soon :crossed_fingers:


One last thing you folks can try to potentially fix it:

  1. Delete the Monzo app.
  2. Restart your phone.
  3. Head to TestFlight, tap on Monzo (the logo not the install button), scroll down and tap on previous builds, tap on an older version (I’d suggest 5.54.0 at the bottom for the highest odds of success), tap install.

This should fix the bug, assuming it’s relatively new that was introduced in a more recent build.

Please report back if this works or not and include which build(s) you tried. It’ll help others who have this issue, as well as the iOS health team pinpoint what might be causing it.

Had the same issue today with TestFlight v5.64 auto installing. Simply reinstalling the App Store version v5.63 over the TestFlight version fixed it. Suggest turn off TestFlight auto-install for the Monzo app just for the time being!

1 Like