Monzo app crashing before opening up

My monzo app won’t open, fully updated both app and iPhone. It spends 20 seconds trying to load and then takes me back to the home screen of my phone. I’ve deleted the app and downloaded it again. I’ve reset my phone and tried turning it off and on again with no results.
I downloaded the TestFlight app to see if that works but still nothing. It told me that the app crashed and asked if I wanted to share this with the app developers which I did.
Any help would be appreciated

What phone and OS version are you using?

DId you restore the iPhone from a previous phone backup (which included the Monzo app/data) and then try & run the Monzo app?

Other users have reported this causes issues - if this is the case, uninstall completely, power-off & reboot the iPhone, then install the Monzo app.

iPhone 8 and IOS 13.3

email or phone the number on the back of your card

There have been a couple of other reports of this so hopefully they’ll be able to find a fix

I have done now, still no good. I’ll be ringing the helpline on the back of my card today to see if there’s a solution.

1 Like

Wondering if you had any luck and got this sorted? I’ve been having she same issues for weeks and haven’t been able to call them yet

Unfortunately not, definitely get in contact with them to let them know because I’ve had emails from them with updates about what they are doing to sort it. But in short I’m still not able to use the app.