Magic Link error on logging in for auth code

Hey guys, so I received an error with getting a magic link for logging into my Monzo account for getting an authorisation code so I can access my financial details through the API. I don’t have this problem if I want to log in for getting an access token, this only happens for giving permisions to my confidential client. This is a problem because then I can’t get a refresh token.

Steps to reproduce Monzo error

  • Fill in Monzo Security to get the authorisation code according to docs.monzo.com

  • Enter the URL in the browser

  • You will get the login page, press “Continue to login”

Type in your email address for the account you want access to

After these steps I got “Oops!” and “There was a problem sending your magic link :thinking:” along with “Problem details :hammer_and_wrench:” with below it “Unknown error”.

Does anybody have any clue why this is happening? Why can I log in and get an access token but I can’t log in to give permissions to my client?

Thanks!

1 Like

This error generally happens when the url followed is malformed such as:

  1. The tokens provided by Monzo when registering the endpoint are incorrect
  2. The unique id that you send as part of the request is missing
  3. The callback url doesn’t match the one used to register the endpoint
  4. Any required parameters missing
1 Like