Authentication Broken?

Anyone else having issues with OAuth authentication? While attempting to obtain an Authorization Code, Monzo is stumbling attempting to send the magic link for login with the error “Unknown error”.
The configuration of the URLs/Client ID/Client Secret/etc. are correct as this has been working for many months now.
I’ve also attempted to setup a new OAuth client to test via Postman and get the same error.

Looking at browser dev tools, the actual error is “No user with that email address was found” even though

  1. as mentioned previously, this was working before
  2. I can log in to the developer playground with the same email address (interestingly, the dev playground also authenticates via OAuth but it must be using a different system. Odd.)

So it looks like the issue lies with Monzo but it would be nice to have confirmation from someone else that utilises the API.

Side note, it’s also a bug that Monzo displays “Unknown error” when the error is clear from the JSON payload. Perhaps it’s related?

1 Like


Yes I am also receiving the same error, where the Magic Link is showing an “Unknown Error” when submitting the correct email upon authentication.

I’ve submitted a request through the app to see if they can help fix the issue, but haven’t heard anything back yet.

1 Like

Yes it is broken for me too … & same error “no user for email found”

Exact same issue for me, I’ve changed nothing with my config, tried to create a new token and the same error. This project has worked fine for years, glad to see it’s not my end. I’ve reported in app too a few weeks back but haven’t heard anything.

1 Like

An update from support, they have literally told me to come back to the community forums and find an answer…

Do any of the Monzo devs look at these pages?

Still having the same issue.

1 Like

Same issue as above. Dev playground works fine.

I checked my client details are all correct, even recreated it, but I cannot login using Oauth for my personal app.

How tf is this still broken after 22 days

Hey! Thanks for raising this.

Sorry for the disruption. We’ve investigated and put a fix in place - let us know if you see anymore problems :pray:


@WilliamRay Thank you, this is working again! :raised_hands:


Is this fixed? Mine still saying unknown error

@WilliamRay Thank you for this, can confirm it works now