Acquiring Access Token Issue

#1

I’ve retried this a few times and not managed to work out what’s going wrong.

I’ve created a link that directs the user (me) to get an access token for my own client. I can’t see anything wrong with the link compared with https://docs.monzo.com/#acquire-an-access-token, the format seems to be fine and correctly encoded.

On clicking the link I get directed to the usual Monzo auth page, it recognises my oauth client by name so something is working but when entering my email and clicking submit nothing happens.

Checking the console, a call to another api.monzo.com url is returning 400, bad request.

i’m not really sure where to go from here. Does anybody have any suggestions?

1 Like

#2

A little more detail, this is the url I’ve generated and it get’s me as far as the screen to enter my email…

https://auth.monzo.com/?client_id={thisbitmustberightitreconginisesmyclientonthenextpage}&redirect_uri=https%3A%2F%2Fpenguin.linux.test%3A5001%2FMonzo&response_type=code&state=229e8c0a-5daa-4017-ad2a-f9835a49f128

0 Likes

#3

Oh wait, after days of it not working it’s just worked…

[edit] nope, stopped again

0 Likes

#4

Solved!

Seems the redirect uri from the request must be in the ReDirect Urls in the client setup. I must have missed where it said this :neutral_face:

1 Like

(Dan) #5

Haha glad you sorted it :slight_smile:

0 Likes

(Che Armstrong) #6

I seem to be having this same issue. :frowning:

I’m trying to create a simple Alexa skill (for personal use for now) - I’m using account linking to get my access token. When I enable the skill I am re-direct to the page to enter my email address, but when I try to submit, it does nothing.

I tried entering the re-direct URLs too - the same also happens when I try to use Google’s oAuth playground (I added that URL as a re-direct URL too).

Do I need to provide a scope or anything? Any ideas?

0 Likes

#7

What’s the error message coming back from the page the submit button is calling?

0 Likes

(Che Armstrong) #8

I’ve managed to get further. I needed to change the Alexa skill to ‘Credentials in request body’ for the account linking - still unable to link but I was able to submit and got the email. Going to see what the next issue is.

Thanks.

1 Like

(Dimitar Chakarov) #9

I am building a sample app for iOS and I am having the same issue. I tried copying the url to my Mac and there I can see the error when I “Inspect” in Chrome - it’s 409. Any help is appreciated.

P.S. In redirectURLs I have the redirect URL I am using in the URL: monzo-je-random://auth

0 Likes