Issues recreating account?

Hi, I’ve been trying to sign up to Monzo since Sunday. I used to have a Monzo account but I used the current account switch service to close it, what a mistake that was. I am now trying to reopen the Monzo account but have hit countless problems. The live chat team have been very helpful to resolve some of them (like being able to use my email again and get past the telephone verification phase).

But now the Monzo app keeps rejecting me because it thinks I already have an account. I let Monzo know this on Monday and they have told me it has been escalated to a specialist to investigate why this is happening and how they will resolve it. I’m not sure how long this will take but looking on the forums I see other people have had similar or even the same issue in the past.

So does anyone from experience know how long this will take as I’m still waiting to hear back and don’t have any time scales.

What device and OS are you using?
Have you been informed by Monzo that the new/re-opened account is now active?
Is a physical card on it’s way or already arrived?
What exactly happens when you open the Monzo app?

I’m on a Samsung Note 9 on the latest OS, can’t remember which one.

I can get through to the end of the Monzo sign up process and then the app says it can’t offer me a Monzo account and my only option is to close the app.

So I believe the account is not open yet.

Already spoke to Monzo and they said it is a mistake on their part and they will look into it. But trying to understand if anyone else had this and how long it took so I can do a bit of planning with my bank accounts.

OK, thanks for the update. Accessing the account will be through Monzo only (no-one on the forum will be able to help with this unfortunately)

I’ve not closed an account and tried to re-open or tried to open a new account after closing one with Monzo either.

Good luck :crossed_fingers: - I’m sure it’ll work out!

When I’ve read other peoples experiences on here it differs to what you’re saying.

If you used to have an account you need to contact Monzo and they will re-open it. Then you can log back in and continue to use it.

If they’ve done this, why are you trying to re-register? This is probably why you’re getting errors and such.

This exact same thing happened to me.

I closed my account with the CASS but I could still access the app.

When I contacted them on live chat to re-open the account they completely removed my account and told me to delete all the data for the app.

When I attempted to re-join, I got as far as doing the selfie video etc. After that, I was told they couldn’t offer me an account and all I could do was close the app.

I DM’d them on Twitter and explained what happened and they took a few days to sort it (and send my card). It looks like I reported it on a Thursday Afternoon and it was sorted on the Monday Afternoon :slightly_smiling_face:

OP, have you tried logging in as if your account was active, rather than trying to re-register? It could be that your account has been revived and you just need to use the login route now. Give it a go at least.

Ah yes, that sounds exactly like my problem. I contacted them on Monday so hopefully won’t take them too long by the sounds of it. I was thinking it may take weeks, but if it was only a few days then I think I should be ok.

1 Like

I can’t do anything with the app except close it, that is the only option I get as soon as the app opens. If I delete the app completely and clear all data, then redownload and login to my account. After login I am taken back to the exact same screen where my only option is to close the app and nothing else.

1 Like

I found a screenshot of the screen I had

Yep exactly that.