Issue accessing Savings & Investments

Issue: Unable to avcess investments since last night. Screen hangs and doesn’t load.

Details to reproduce: Select Savings/Investments from account/home screen.
OS: iOS 17.3
Device: iPhone 15 Pro Max
App Version: 5.58.0

Tried resetting session in Settings, deleting app & installing TF/App Store versions and logging in/out.


Just been into mine this morning to check out the new Switch fund option with no problems.

iPhone 13 Pro

Interesting, I am still experiencing the same issues.


I can now access the page but it has a holding statement. Advisor on chat said it should be resolved today.

1 Like

Exactly the same experience here.

I actually needed to access some of my savings today, helpfully Monzo support were able to transfer the money for me from my savings to my current account.

1 Like

Similar issue here on Android. The page loads, but my investments balance won’t refresh and an error is shown saying:

“Something’s gone wrong, please try again in a few minutes”.

This has been happening for at least a couple of days

1 Like

Hi @jasonhihello & welcome :wave:

If your device doesn’t have internet access (or access, but very slow), you’ll see this message along with others. If the internet connection is OK and reasonably fast then it could be an issue with the configuration of your specific device. Randon issues are often fixed with the uninstall/reboot/reinstall dance :bananadance: :

  • Uninstall the :monzo: app on your device
  • Reboot your device (important)
  • Download/install & log in to the :monzo: app
  • Check the issue is fixed

Hi @davidwalton

Yep, tried all of that before posting.

It turns out it was an issue on Monzo’s side which was fixed a few days ago.


1 Like

Thanks for the update & good to hear it’s working OK for you now.

(Keep that dance in mind, in case of irritating issues cropping up!)