[iOS] Notifications vibrate even when DO NOT DISTURB is on

Switching on DO NOT DISTURB on an iPhone is meant to silence all calls and notifications. This doesn’t quite work with the Monzo app. When my Direct Debit payments are taken at 3-4am, Monzo causes my iPhone to vibrate - which invariably wakes me up, since I sleep with my iPhone by my bedside and use it as an alarm clock. This morning, I was aware of this at 03:11 and 03:31am.

I know I could altogether switch off vibration. However, that would mean I could no longer detect incoming calls and notifications when my phone is on SILENT. Might there be a way for Monzo to tweak how their notifications work, so the iPhone no longer vibrates when notifications are received when DO NOT DISTURB is on?

Sounds like you have encountered an iOS bug rather than a Monzo bug. There’s nothing Monzo could do to make your phone vibrate while it’s in DND and screen turned off even if they wanted to.


Unless Monzo is not registering correctly so DND isn’t kicking in?

Nah, a notification is a notificaiton – and DND mutes all notifications while the screen is off.

Or at least it should.


Fair enough. Had an odd app in the past that had to reinstall a couple of times before it ‘behaved’ correctly.

@hdwrng, thank you for your response. I actually hadn’t considered that. It suggests I should try uninistalling and reinstalling the app, and monitoring its behaviour.

I’ll feed back on this thread.

I’d be interested to hear whether other users have had the same issue.

Haven’t had the issue myself, but I second this. Monzo will deliver the notifications regardless of whether DND is turned on. It’s up to the iPhone to prevent them from sounding.

If reinstalling the Monzo app doesn’t work, it may be worth erasing and reinstalling the software on your iPhone :slightly_smiling_face:

1 Like

Big long shot coming up.

Is your phone locked overnight? Some people use it as a bedside clock. There’s a setting in DND to only disable notifications when the phone is locked.

1 Like

I did keep saying “while the screen is turned off” in the hope that people would have a quiet lightbulb moment and realise that’s what their issue was.

Sorry! I clearly need to refuel my coffee powered lightbulb. :bulb:

1 Like

Hi @Anarchist, yes, it auto-locks after 3 mins - so that’s not the issue. Thank you for checking with me, though!

Maybe next time be more explicit?! :smiley: Clearly we are all without lightbulbs today…

Might not be a thing - but have you turned vibrations off as well? I know that for silent mode at least you can have a vibration on and off version - although still doesn’t account for the notification pushing through DND.

As I understand it, I shouldn’t need to toggle it on and off every time I go to bed. Vibrate is useful in a multitude of situations - both when the sound is on and when it’s off.

1 Like

Thank you all for your responses to the issue I’d raised. I’ve now reinstalled the app. It’ll be a few more days until I know whether it has worked, since I don’t have any scheduled Direct Debits until the beginning of the month.