[iOS] Keyboard doesn’t appear when asked for pin (and touchId bailout fails to work)

Keyboard doesn’t appear when asked for pin (and touchId bailout fails to work)

The issue is no longer apparent after taking the time to write this bug report so some remote dependency might have been the culprit. (Thanks for fixing it if that was the case!)

Details to reproduce:
Given I’ll be required to re-enter a card pin on next use
When the pin confirmation blocking modal appears
Then I expect to see the iOS keyboard or another input method
But I have no way to input the PIN numbers
And I see a permanent data loading indicator on the top left of the screen (screenshot 1)

When I use the touchID option on the top right
Then I expect to be able to use touchId to unlock the app
But the screen is blank
And I can see a permanent data loading indicator (screenshot 2)

iOS 13.3.1
iPhone 8 Plus
App Version:
Latest on Feb 17th, 2020, 6:45AM GMT


Hi - I have exactly this problem now. Do you have any idea what causes it?

Hi! I’ve just experienced the same problem. I’d say it’s quite urgent big to fix, not allowing to access the app.

Worth checking, in this order:

  1. Are you running the latest update of the app?
  2. Have you tried restarting the phone?
  3. Have you tried deleting and reinstalling the app?
1 Like

Hey @horothesun just following up to check if you’re still having this issue?

The steps from @HoldenCarver above are usually the best steps to follow to get this issue resolved :pray:

After multiple attempts, the keyboard appeared and I was able to type in the pin.
I’ve never seen that screens flow again.

Thanks for the replies! :slightly_smiling_face:

1 Like

I have just tried to enter my pin multiple times to get into my account, I know my pin off by heart it was not letting me into my account, I even done a pin recovery came back with the pin I always use, I had to switch my phone off then get monzo to send me another email to log in eventually my pin worked, so not sure what’s causing the problem getting back into account once logged out

Just happened to me on an iphone11 (so no touchID). Flipping away from app and back and restarting it a couple of times got me past the faceID check and a visible keyboard to type the PIN with. I did notice the keyboard sliding out of view a few times whilst doing the faceID check

iOS 13.5
Monzo 3.35.0