[iOS] Incorrect date for transactions

#1

Issue: incorrect date shown for transactions if the app isn’t force quit after midnight and is in my most recently used apps (say 10-12 most recent)

Details to reproduce: see screenshot - the “WOLF” payment is from yesterday and the two penny saver Pot deposits are from Saturday night and Friday night respectively.
If I haven’t used the app in a while and it has cleared itself from my active apps (usually 10-12 most recently opened stay passively running) then it works fine. If I’ve used the app in the few hours preceding then it won’t work and has to be force quit.
OS: iOS 12.1.4
Device: iPhone X
App Version: Monzo 2.41.0 but has been happening for at least a month or 2.

Screenshots:

Yesterday's transactions temporarily shown as today's in feed
#2

Monzo use UTC as the internal app clock. When the clocks changed UTC midnight is at 1am, so transactions made between midnight and 1am will show as yesterday on your feed (I think).

Also, have you checked your phone’s clock is correct? I’ve previously noticed that changing your phone clock effects the feed date labels.

1 Like
(Emma (still not the app)) #3

Pots are all over the place at moment recording transactions

It works on UTC so if you’re buying just after midnight it registers as yesterday

Edit: see above :grin:

1 Like
#4

Yeah, my clock is auto set rather than manual so comes from the iOS.

I’d understand that if it were just the case of the last transaction - but that doesn’t explain the two Pots payments surely? They’re 24 hours apart because they’re set for 11pm daily on the penny saver IFTTT applet. They should still show on separate days, no? :thinking:

2 Likes
(Emma (still not the app)) #5

Some people are reporting several days before IFTTT transfers are correctly showing in the app. It’s an issue at the moment that hopefully will be solved.

#6

Thanks @Rat_au_van :ok_hand:t3: Good to know!

1 Like
#7

Yeah this issue has been going on for ages now. Nothing to do with UTC.
Even checking after 1am unless I force quite the app translations still show up as “today”. Been an issue for months and I haven’t seen anyone from Monzo acknowledge it yet.

#8

Yep @monzo2018 , still happening at 01:39 :pensive: so definitely not UTC.

Fingers crossed for a fix soon. I work 5pm-2am so it’s not unusual for me to be on the app until 3am sometimes.

1 Like
#9

I decided after midnight passed on Friday, not to force quit my app (as I have become accustomed to having to do every single day) - to see how long it would be before my transactions actually displayed on correct day. I knew it would still not have corrected itself in the morning, as that’s how I first noticed (months ago) the issue, and started force quitting the app every day.

But I didn’t know quite how long it would take… 26.5 hours!!
So until 2:30 am on Sunday, my latest transactions were still all lumped into “today” with Fridays transactions. As I knew I was testing this, I was also opening the app over that 26.5 hours much more frequently than I usually would to check if it had corrected itself. Over the past few months I’ve had to reinstall my app a few times for unrelated issues, and so clearly a fresh install does not fix this bug.

Please can someone from Monzo take a look at this :eyes: as I think 26.5 hours before the feed shows the transactions against the correct day is kinda annoying and I would like to not have to always force quit the app.

iPhone X
Monzo 2.43.0
iOS 12.2

Messy annotated screenshots to follow.


(Emma (still not the app)) #10

What time and day does it say on the actual transaction itself? Very strange, not an issue I’ve encountered. I think in app chat might be the best option

1 Like
#11

If you drill into the transaction they always show the correct time, and I think, the correct day as well (I’ll check after midnight tonight) it’s just the feed that messes it up.

I could message in app, but felt like it would be easier to demonstrate here, and I don’t necessarily want to waste a c-op’s time when Monzo devs do seem to (usually) check bugs reported on the forum.

(Emma (still not the app)) #12

Hard to know what they’ve seen and what they haven’t but this seems to affect very few people (ie just you really). Personally I’d go down the COps route and possibly link to that detailed post after explaining. At least then you’re sure it’ll be passed on

You don’t have any region settings on? Can’t see how that would cause it but you never know

1 Like
#13

:joy: there’s at least one other! I didn’t start this topic :wink:

In all seriousness though surely it must be affecting more people? With an iPhone X, and always on latest iOS/Monzo version - I know there are infinitely more variables, but there’s gotta be more people :joy:

I’ll give them a message then, see what happens :blush:

1 Like
(Emma (still not the app)) #14

I would have expected more reports tbh if it was a wider issue, but what do I know? :joy:

Hope you get it sorted :crossed_fingers:

1 Like
#15

I know, you would expect so! Not that I want others to experience this issue, but I kinda hope it is more widespread than 2 people otherwise it might be difficult to get a resolution :slightly_frowning_face:. Will see what happens on the in app chat anyway :blush:

1 Like
(If there's the wrong end of a stick, you'll find me holding it.) #16

I started a thread on this some time ago. CBA to search for it, but basically if you don’t let the app close, the transaction feed doesn’t get the date change at midnight. I never did the 26 hour experiment, though (too impatient).

1 Like
(MikeF) #17

I’ve been seeing this for ages but it’s never really worried me so I’ve never bothered to mention it. It’s just ‘one of those things’.

1 Like
#18

It didn’t bother me for a while, but then it started to annoy me when I realised that I was having to force quit the app every day - as much as I love Monzo, I don’t need to force quit any other app every day for it to display updated info correctly :smirk:

#19

Do you force quit the app once a day then? Or do you find it rectifies itself much quicker than my recent test haha? I’m gonna see what happens after midnight tonight/throughout tomorrow (minus the screenshots :joy:), and see if it’s as long before it updates again.

Up until testing it over the last few days, the longest I’d left it before force quitting was when I made my first transaction of any given day, so this is actually the first time I’ve let it play out without force quitting at all.

(If there's the wrong end of a stick, you'll find me holding it.) #20

I think iOS will close apps which are running in the background if it needs the memory for something else. If that happens (or I force quit the app) just before midnight, then it’ll work as expected after midnight. I only seem to see the issue if the app is running (either active, or in the background) at midnight.