[iOS] Apple Pay Not working

I am having the same issue I upgraded from an iPhone X to an iPhone 11 last week. I cannot get the Apple Pay working. I am having the exact same issue and getting very little support going back and forward with Apple and Monzo and no one is taking ownership!

1 Like

Also I have just added on my NatWest card with no issues so the issue is a monzo issue not Apple!

1 Like

If it’s like the issue I had with Google Pay when I upgraded phones, you need to contact Monzo and ask them to reset the verification process (I think that’s what they did to fix it for me after I explained it kept looping).

It may be you got a COp who was reading from the wrong script, or misunderstanding what you were asking, so I’d try again and hope you get a better response.


Worth noting that Mastercard is also in the middle of this process between us and Apple. Even if a Visa card works fine, it may still need to be escalated to Apple and Mastercard after we try all the possible fixes we can. :slightly_smiling_face:


Anyone manage to fix this issue? Having the same issue any help is great, tried ringing and contacting the help chat room with no reply from either for hours

I found trying to manually add the card again (without deleting the one that says verify in the Monzo app) made this work - maybe it forces some communication to happen in the background?


Thanks! You’ve just saved me a lot of pain by having to call Monzo and wait who knows how long in queue.

Adding the card again without deleting the failed verification made the trick.

You beauty! I just registered especially to say thank you - this has been bugging me for days. Manually entering the details pushed the other card stuck in verification through!


Yes! This worked for me too. Amazing and thanks for sharing!

1 Like

You beauty! :star_struck: I’ve had this problem for weeks after getting a new phone!

(had called Monzo and Apple with no luck!)

1 Like

Well I just upgraded my phone to iPhone 11 and I fixed by making my monzo card a travel express card hope this helps

1 Like

Thank you. I have tried and it worked

1 Like

Made an account just to say thank you


Yes! This works, thank you!

1 Like

This is an interesting solution and one I’ll take note of :thinking:

If anyone else is having this issue and manually adding the card doesn’t work, please try the below:

I tried this on the suggestion of COps when I was having the problem, and it didn’t seem to fix it. After that, COps suggested I report the issue to Apple, which was when I stumbled upon the solution I found

Thank you very much. I had been suffering with it for hours.

Setting the card to travel express is what worked for me. Thanks.

Adding the card manually, with out deleting the old one, worked for me.

Thanks for the help!

Spoke to people at Monzo via the in app chat and they were useless. Not sure why they can’t just relay what was said here by the community. Instead they told me to call Apple.

1 Like

Thank you! Solved straight away.