Face ID Bug

Every time I open the Monzo app when I have finished using it as I try to swipe up Face ID gets triggered again. So as a result you can’t close the app straight away.

It’s been doing it past you build with iOS and the Monzo app.
OS: 13.5.1
Device: iPhone 11pro max
3.37.0 #644

have you try deleting the reinstall the app again

I’ve had this issue for a few months now.

After running the app, if it’s closed from the multitasking screen, Face ID gets triggered again and the screen board of iOS goes blank for a minute before the app closes.

Has happened with the last few Monzo releases, as well as various iOS versions.
Reported via in-app chat at the end of March and went through the usual troubleshooting (log out, log back in, delete the app, ensure latest version of both app and iOS are running etc) and was raised as a bug as it only happens if the app Face ID setting is turned on.

Happens on a daily basis as it’s not really feasible to leave Face ID off, as you can log into the app without any sort of security measure

Glad it’s not only me with a problem thanks for your reply !

1 Like

I’ve the iPhone 11 Pro and I’ve not been able to repeat what you’re experiencing. I know Apple have changed the face unlock to enable people to swipe up from the bottom to type in your code, this is for people wearing face masks.

I generally only close an app on task manager if it’s faulty or not working.

I tried lots to see if I could trigger the problem you’re experiencing and I couldn’t.

Do you have Face ID setup to unlock the app in the first place

As far as I’m aware this does not apply to Monzo app as it is not possible to bypass Face ID unlock with a passcode.
This was also a feature (Face id bypass for users wearing masks) that was only introduced with iOS13.5, and this has been happening since before Apple released.

Managed to record my screen whilst happening.
@karl76uk I’m assuming this is the same thing that’s happening to you?

Edit: seems like I can’t attach the recording, anyone know if it’s possible at all to add videos to posts?

Edit 2: managed to convert it to a gif and attached it below


Worth noting that this happens as well on iOS 14 beta :eyes:

That helps thank you for testing it !

1 Like

Yeah same thing on my iPhone as well !

1 Like

So, I’ve just updated my iPhone to iOS 14 dev beta 5, and the issue seems to have sorted itself?

My app has not been updated for a couple of weeks, as I have not updated to the version that hides the transfers information, so it is unlikely that an update of the app solved the issue, as I was experiencing it only this morning.

If it is something that has been changed remotely, from a server side, then it would be a huge coincidence that it was changed at the same time as updating iOS :joy:

Digging up this old thread with an update.

The issue still persists. It came back shortly after it went away and it still happens to date.

Got a new iOS device and after installing everything fresh (no backup used), it happens on the new phone as well so does not seem to be device-specific.

Noticed that the only other app that has this same bug is Plum :face_with_monocle:

I’ve still got the same bug iOS 14.2 and the latest Monzo app. I just gave up ! iOS 14.2 is just so buggy Apple should be ashamed!

Apologies to bump up this old thread! Just wondering if this is a widespread issue or if anyone else has started experiencing this as well.

From the posts last year it seems like only a handful of us were experiencing it.
Reinstalling the app didn’t produce any results, I’ve even changed my phone since, and there has been a few iOS updates, as fell as a few more Monzo updates, and this is starting to after the UX when using the app on a daily basis, as a main bank, as it triggers the Face ID every single time the app is closed.