Declined at Amazon. App saying use chip and pin

Hey folks,

Trying to buy a new charger cable on Amazon and am getting some weird things.

First attempt was debited and then immediately refunded, Amazon said card declined.

Second attempt was processed successfully, then another transaction pops up saying use chip and pin (this is obv an online transaction and using a virtual card)

Any ideas people?

We won’t be able to provide anymore detail other than what’s in your screenshot, beyond things like trying again later or deleting the card and trying with a “newly generated” one.

If you contact customer support in app they will be able to tell you exactly what the problem is.

hmmm ive just had the same problem the card payment declined it went through the authorisaation and i entered my pin and then a few mins later it says declined i wonder if there is an issue with virtual cards , as i used g pay earlier at the petrol station ok byt that would have came out my main card

edit just tried using my main card and its not worked either