Current Account Beta User, should I have got an migrate prompt?


(Sam) #1

Have the prepaid (blue) iOS app (latest version), but not getting a prompt to move to my already existing current account (access using the old white app from testflight).

People in the forum are reporting getting the prompt but I’ve not seen anything? Just getting wary since the testflight build seems to indicate its expiring and I use monzo as my primary account, so loosing access would be a disaster.


(Harry) #2

Tristan posted this in the pots thread yesterday, there should be a form that you can fill out on the ‘Help’ section of the app to speed this up but I would also assume that Monzo are aware that the white TS app is expiring therefore everyone still on there needs to move over.


(Caspar Aremi) #3

You need to check in the PP app for the banner. If it’s not there, go into the Help Section and you can request to be upgraded.


(Tristan Thomas) #4

You should have received an invite by now! Paging @Jordan who’s the current account upgrade Master :slight_smile:


(Sam) #5

Thanks for the quick reply! Should I wait to get contacted then? I looked in the Help section of the blue app but the Q&A there just says to wait for a banner, couldn’t find a request form. Been checking email/spam too incase the invite went there.


(Adam Prentice) #6

I also haven’t had an upgrade notification, I just assumed it was coming shortly!


(Jen ) #7

I’ve got the upgrade prompt, but it’s asking me to fill in my information again.
Is this how it should work? I just don’t want to accidentally create myself another current account and cause people headaches…


(Hugh) #8

I don’t think it is possible to create multiple current accounts so you should be fine going through the upgrade processes :slight_smile: If anything does go wrong later on you can always contact COPs who will be able to have a look and see what’s going on


(Colin Robinson) #9

@CensoredPixel If it’s asking for your current address I think it’ just confirming where you live?


(Jen ) #10

@Dunsford It’s asking for everything I entered when I registered for my CA (name, address, DOB, agreeing to terms etc). Just don’t want to do anything stupid if this isn’t the way I’m supposed to do it haha.


(Colin Robinson) #11

I saved my screen shots from when I upgraded so yes it does ask for full legal information, then current address, then confirm address, option for news and updates, T&Cs, etc. so I’m pretty sure you’re ok :slight_smile:


(Hugh) #12

:+1:
They always come in handy :wink:


(Ben Yafai) #13

I had the same thing, just follow the process and confirm your identity, accept terms etc.
Then my CA and PP accounts were merged (balance transferred) and I deleted the testflight beta app.


(Jen ) #14

@Dunsford, @crablab & @yafai - Thank you!
Put my mind at ease :slight_smile:


#15

I had the notification in the PP app which I went through, verifying address etc.

However, I am now left with a PP app that shows balance of £0.00 so it hasn’t merged the balance of my current account + PP account. Also I have a blue banner at the bottom of the PP app saying “Finish setting up your current account. Tap here to continue” but if I tap it then I just get a black screen. I have also noted that on the “Account” tab it shows my card as being frozen and no AC number or sort code.

Does anyone have any ideas?

Pictures for reference, the black box is masking transactions, not the black screen I mentioned :slight_smile:




(Change Works) #17

Looks like you fell between the cracks :grinning:

After the usual force quitting the app and re booting your device, I’d send help@monzo.com an email. Unless you can access in app chat


(MikeF) #18

That needs an in-app chat with COps to sort out I think.


#19

Cool thanks guys. I have tried the standard stuff so will drop a message to in-app support :slight_smile:

Edit: As a FYI for others reference, a reset of the app resolved my issue.


(Hugh) #20

Yeah, I think this is a known issue with the iOS Current Account app unfortunately. Hopefully will be fixed soon :ok_hand:


(Sam) #21

This weird black screen/broken app happened to me. I just left it and within a couple of hours it all sorted it self out on its own and everything seems to be working normally.