Created new account but app now wont respond

I created a new account but the app froze at one of the final steps and when I try to login now the the app doesn’t respond just get a wait spinner.

I have tried completely closing the app and deleting and re-installing it, still the same issue.

Have you tried restarting your phone?

Yes and tried deleting app, restarting phone and restarting the app

If the wait is substantial, I’d suggest you email Monzo on (from the email you signed up with if possible) and let them know what happened when the app froze. They should be able to find out if it’s anything their end that’s stopping the app from loading, and if the application process was successful etc.

Thanks, email sent

I’m having the same problem. I got to the fingerprint recognition and it hangs.
I’ve deleted and re-installed the app 3 times now, switched my phone off and on, and re-set the app in my settings but the same thing happens every time. I get the email to login, click through and it freezes again.

I’m on an Iphone iOS 11.2.6. I’ve emailed support but no response yet but I’ll update if they get back to me soon.

Yes exactly the same point for me, thanks. I am on iOS 12.1.4

Just had a response from Monzo, this is a known issue discovered yesterday, hopefully a bug fix coming tomorrow.