Contactless on Edinburgh trams ticket machines


(keithy) #1

Contactless didn’t work so proceeded with chip and pin which was accepted. Transaction showed up in Monzo app. Ticket machine froze without dispensing ticket and after a few minutes crashed and rebooted - still no ticket.

They appear to run on Windows 10 so no huge surprises :grin:


(Ian Lyon) #2

Sorry to hear that @keithy :pensive:

Give us a shout through the in-app chat and we’ll be able to look into this for you :+1:


(Harry) #3

Happened to me a few months ago and I had to use another card and wait for the authorisation to be reversed on Monzo (takes about a week).


(keithy) #4

Thanks. It’s all sorted - they manually gave me a ticket after showing them the traction in the Monzo app :grinning:

This was similar to what used to Happen with the south West trains ticket machines. Thought you might like to hassle them directly to maybe get their machines updated


(Hugh Wells) #5

I’m going up to Edinburgh today (not a Monzo thing) - I will make sure to check this out :+1:

Would you be able to let me know the specific station and machine you tried so I can see if I can reproduce this?


(keithy) #6

Hugh,

This was at the airport. There are 2 sets of machines as you approach the tram stop. One set directly infront of the trams which are often busy and another set of 4 off to the left.

It was the right hand most machine of the 4 on the left.

Hope that makes sense

Keith


(Hugh Wells) #7

Cheers :+1:

I’ll see what I can find out :mag:


#8

Is this one of those online/offline transaction issues?


(Hugh Wells) #9

:woman_shrugging: I’ll find out :blush:


(Jolin) #10

As a point of reference, I successfully used Monzo contactless at the Edinburgh Trams machine at Haymarket last month.


(Hugh Wells) #11

Just worked for me :+1: I suspect this may have been a BIN whitelisting issue in the past


(keithy) #12

Ok. Strange. Why did it work for you and not me???


(Kevyn) #13

Could it be an older current account preview card? I remember v1.0 cards had issues with some processors due to having older, less developed chips.


(Hugh Wells) #14

The BIN is the first 6 digits of the long card number - that’s 535522 on the current account. Sometimes, to prevent certain cards being used machines have a whitelist of BINs that are not allowed and if the BIN isn’t on there the transaction won’t be processed :frowning: As out BIN was fairly new a while ago, some machines weren’t updated but it seems these ones have been :+1:


(Andre Borie) #15

A forbidden BIN still shouldn’t cause a crash though.


(Hugh Wells) #16

I refer you to this thread :slight_smile: Same card machine. The bug was fixed in a software update that has been rolling out gradually and reached most machines now


#17

AHH Edinburgh trams, im sure last time I had to buy a ticket I had to use my pin. Thankfully I currently only use it for airport visits.