Sign up Not Working within app for Iphone

I cannot get the app to upload my security details so that I can confirm my registration for a Monzo card

What point is it getting stuck at and what error message are you getting?

Camera working? Sound ON? Access to Internet (WiFi/mobile data)?

Have your tried delete the app what part douse it get stuck on you could try resting network setting some time that helps.

You’re being too vague so it is very difficult for us to help.

You need to give us as much information as possible. The steps you’ve taken so far, what you’ve tried to resolve the issue, the error message you received, the phone you’re using, OS version, any screenshots and so on… the more detail the better :slight_smile:



1 Like

I have done all the steps it asks for but it simply won’t progress beyond the video upload. I even got to a point yesterday when it put me through to customer service, the rep unblocked my ID (as that apparently was the problem) but the screen returned to that stage again and now won’t move forward. I am going to try with different ID and see if that helps.

Yes I have deleted the app several times and reloaded it including all my security info.

The camera is working and the sound is on and I have full access to the internet.

Very odd I nit sure what could be the issues have your trued resting network in the phone or turn of the router for a few mins if that’s douse not work trying support.

That must be very frustrating! I’d think your best bet is to try calling again and see if they can see something else going on that you can’t.

Thanks for the update.

Just to get rid of any unknowns - you are using the stock iOS camera app (no 3rd party camera app being used)? Also, your phone is stock (not jailbroken or other mod)?

Having the phone on ‘do not disturb’ has also, in the past, produced problems.

This is very likely to be your device (or configuration of your device) that has an issue.

To add to the above.

The apps permission to access the camera/camera roll also have caused similar issues in the past. Worth a check :slight_smile:

Registered users can log in, but do not receive any additional access on the apps.

Are you having trouble with the app? If so, could you try explaining in a little more detail what the issue is so we can help :slight_smile: