Can't get into Monzo App [Resolved]

[Update: RESOLVED]

[Was able to find a help email ‘’. Including ‘URGENT!’ in the title and setting the priority to high, I was able to get a swift reply in less than 15 minutes! ‘David’ was able to change something on their end to help me get in. But I totally agree, I thought it was an app crash thing? My internet was working fine throughout, every app worked except Monzo. Perhaps it just needed to work through the ‘frozen app’ stage and then cooperate with me! Thanks for the responses though!]

It all started over 24 hours ago when I hopped on the app to move some money into pots. It told me that there was an internet connection error, and I should check my connection. I closed the app and re-opened it and the same thing happened, couldn’t do anything on the app. So, I left it for a day in hopes that it’ll sort itself out. Checked Playstore to see if it needed an update, but it didn’t. Fast forward to today… I uninstalled the app, re-installed it and now when I click on the Monzo app, it just shows me the app loading page (Monzo logo on the dark blue background), and nothing. Nothing happens… I’m so stuck… I really need this issue resolved ASAP as I have some important payments coming out and need to move some money around.

Most up-to-date Android
Samsung S10

In which case, I hope you’ve already contacted Monzo so they can start to help while you wait for a customer to come up with a solution. It looks like you’ve already tried anything I would suggest.

Hope it gets resolved soon :+1:

This is going to be a phone problem rather than a Monzo problem and it sounds like you’ve tried all the logical steps.

All other apps working fine? Got an internet connection?

Do you have an old device/friends/partners that you can install Monzo on to do what you need to do for now?

Hey! Thanks for the reply, I’ve been able to resolve the issue! Not quite sure how… but eventually it loaded the login screen. Fingers crossed it doesn’t freeze again.


Glad you’re sorted!

15 mins email response time is a borderline miracle :rofl:

1 Like

Hey! Yeah all apps and internet connection were working fine. I was able to get it resolved in the end! Not quite sure how, but it eventually loaded up the login page. A Monzo staff member did say he tweaked something on his end, but I’m not sure if that contributed to the app finally loading or not. Either way, crisis over!