Cannot move money with decimals

Issue: When moving money between my two Monzo accounts (one joint), the input box for the amount gets reset to zero every time I press the “.” button to enter the fractional part of what o want to move.

Details to reproduce: Move money from personal to joint account. Set amount to 1.5
OS: android 11
Device: ZenFone 8
App Version: 4.13.0

Hi Lluis & welcome :wave:

I’ve just tried the exact steps and it works OK for me - I’m able to enter 1.55 as an example amount to move money from my Personal account to my/our Joint account.

Android 12, Pixel 5, Monzo app (beta) 4.14.0

Try uninstalling the Monzo app, restarting your phone, then downloading & installing the Monzo app again. Doing this has historically cleared a lot of strange in-app niggles for people.

Tried a different keyboard, like Gboard? May be worth a try.

I’ve just tried it and it all works fine for me too. If you’re using a custom keyboard that’s a good thing to check and rule out.

I did notice that it annoyingly finishes the amount off for you when you’ve entered the first digit after the decimal point. So £1.6 then it sticks a 0 on the end so you have to delete this if you want to enter a different amount.

Alas, works fine for me too. Android app.

I only have the default android keyboard (gboard). The phone is almost stock version from manufacturer.

Uninstalling, rebooting and reinstalling did not fix the problem either.

On your phone, is the System Language set to ‘English(United Kingdom)’?

Aha! Changing the system’s language back to English fixed the problem. Thanks!

While in a non-English language (Catalan or Spanish), the “.” problem shows up, and the numeric keyboard shown in Monzo (via Android’s Gboard), does nothing if I press “,”.

1 Like

Good to hear the issue is ‘fixed’ for you - thanks for the feedback :+1:

There have been a lot of language-based issues with the app over the years.