Can’t add Apple Pay

(Adam Northover) #1

New to Monzo. The app ‘can’t retrieve my card’ and advises me to try later. I’m overseas on a British VPN, I wondered if that might be the issue? Any advice welcome. Thanks

(Kolok) #2

Can you try without the VPN?

Also there should be a button inside monzo by the card tab to add it straight to Apple pay, does that work?

(Adam Northover) #3

Afraid I can’t at the moment. Only got internet access through VPN. The add button isn’t working. Thanks for the reply though

(Kolok) #4

It’s the Apple pay app saying can’t retrieve the card, right?

Can you uninstall and reinstall Apple pay?

Maybe contact monzo support in app ,

One thing, maybe turn off location, restart the phone and try add the card again,

(Jack Stride) #5

I had that issue a couple of days ago where I couldn’t add it via the Monzo app but if I tried through the Apple wallet app then it worked.
Have you tried both methods?

#6

What country and what VPN?

(Steve William) #7

When I was trying to install itunes on windows 7 it was not installing at all and after that, I tried to install the app with admin privileges but still, it was not installing at all. Please help me to fix the problem.

(Sarcasm is the finest form of wit.) #8

I’d try the Apple Support Forums, probably are a better place to ask questions about installing iTunes?

#9

Have you tried adding it by manually typing the card number and details in ? Also try to restart the phone completely and try to add again. If none of the above works, then VPN is the issue , since when you add the card your information gets shared with your card issuer, which might be seen as incorrect due to your VPN settings.