Balances Not Updating

Issue: When opening the app or switching between the main account and a saving pot, the balances don’t reflect the current balance.

Details to reproduce: Check your balance. (To see current balance), make a successful transaction, check the balance, (It should be correct), switch to a savings pot, then switch back to the main account and the balance should revert back to the balance before the transaction. Leaving the app and re-entering corrects the balance, but switching between a pot and the main account replicates the issue again.
OS: Android 9
Device: OnePlus 3 A3003
App Version: 3.12.1

How long have you been having this problem?

Have you tried deleting and reinstalling the app to see if that fixes it?

I’ve experienced a few instances of this happening recently. There doesn’t seem to be any pattern to them, other than there’s also been an indirect(?) issue on the Monzo side (delayed payments, payments can’t be made, etc.) and then after this, the app starts to show an incorrect balance.

The quick fix seems to be to tap on ‘Payments’ then tap on ‘Home’ and the correct balance is shown. After the last ‘delayed payments’ occurrence (December 19th -, my Joint Account would show an incorrect balance until I tapped on Payments and then back to Home (this seems to refresh it). But then when I scrolled from the Joint Account to my Personal Account and back again, the JA showed the incorrect balance again. This repeated for 2-3 days.
Eventually, the app corrects itself.

I’ve tried uninstalling, resetting, reinstalling from scratch, the whole shebang and nothing changes it - other than patience and time.

Pixel 2XL, stock Android 10, Monzo (beta) app 3.12.1

Same here on android. Tap Payments, back to Home and it updates.

Same thing happening for me, Android 10 on a Note 10, version 3.12.1 of the app.

Me as well, only started happening the last few day
Huawei P20 Pro running Android 9, latest beta version of the app

Hmm :eyes: I can’t say I noticed that this morning when I bought something on Amazon.

Not seen a wave of reports through Chat about this either but I’ll do what I can to test it out :blush: Good excuse to buy another Domino’s :smirk:

Will let some other folks know too so we can keep an eye out on this :smiley:

Glad that there’s an easy workaround :pray: but it should just work so let’s try and figure out what’s gone wonky :stuck_out_tongue_winking_eye:

1 Like

For me it seems to be when moving money between pots rather than transactions.

1 Like

That I can reproduce :100:

Swiped to my coin jar, withdrew £10. The coin jar balance dropped by £10 but my account balance remained the same :eyes: Until I tapped on Payments and then Home :raised_hands:

(Same happens the other way around, adding £10 to my coin jar reflects instantly on my coin jar but my account balance sticks with a ‘free’ £10 in it.)

Will pass on the info and let some smart folks figure out what’s going on :wink:

Cheers for the report everyone! :hot_coral_heart:

(I would imagine the mechanism causing the balance to ‘stick’ is the same across Pot movements & transactions updating the balance so this is probably just two separate ways to trigger the same issue :pray:)


Thanks Marcus :raised_hands:

1 Like

Good to know it (or a similar ‘it’) can be reproduced. My instinct tells me this is the same display update issue that we’ve reported. It’ll be something simple I’m sure but one that has frustrating - and misleading - consequences if you’re not alert or aware of it :cold_sweat: