Apple Pay top ups failing


( related to Monzo CEO, Investor in Monzo ) #21

sorry if I am misunderstanding ,

  • you have a Barclays debit card that when you enter it into the app the app declines it

  • and you then have a NatWest debit card that you have linked to apple pay which is then also declined by the Mondo app

  • or have you got a registered card on the Mondo app that when you try to top up is declined by either Barclays, NatWest or Applepay


(Adam Hockley) #22

well even when card didnt disapeer it declind to meaning all 3:-)

Yes thats correct

top two


( related to Monzo CEO, Investor in Monzo ) #23

so both cards that you are trying to use Barclays and NatWest are Debit cards and both will not be accepted by the Mondo App ? and you have entered the Debit card details exactly as they appear on the card ? - yet you have been able to top up with the registered card before the 6th ?

  • something must have changed with your card after the original top up this card must have been successful to top up with and must have been passed by your bank ?

(Adam Hockley) #24

Yes stripe isnt accepting it let alone broken


( related to Monzo CEO, Investor in Monzo ) #25

sorry not familiar with stripe - I am old tho :wink: - is it not just a simple case of removing the “stripe” bit of the transaction and go back to how you originally topped up your card presumably by registering one of your two cards onto the app which was successful originally -

  • sounds like stripe might be the problem ?

(Adam Hockley) #26

Its mondo not my bank card i used it before just leave the post for them as there investgating its stripe there payment gateway.


( related to Monzo CEO, Investor in Monzo ) #27

sorry again I must be missing something -You topped up originally with a bank debit card which was OK - you’re now saying “Its stripe their payment gateway” so why is it Mondo that is causing the problem ?

anyway

sorry just trying to help you …;-( …but I will now leave it … thanks anyway :wink:


(Colin Robinson) #28

I think he means this Ian:

https://stripe.com/gb


(Adam) #29

@iansilversides Stripe is the new payment processor for Mondo. It recently changed over in 1.5.1 of the app.

@AdamH I’ve just used my NatWest card via ApplePay and was able to topup (took a while to process) without any issues. As you have said you confirmed it is not NatWest that is blocking the transaction as they are not being presented the details, it would therefore be for :mondo: to look into with their payment processor.


(Adam Hockley) #30

Its fixed James sorted it :slight_smile:


(Dom B) #31

I’ve just had some similar issues with Lloyds Bank. I’ve topped up to Mondo with ApplePay many times before, usually around £40, and now wanted to put £200 on there. Apple Pay declined. Tried multiple times, contacted the bank fraud team who apparently unblocked it. So I tried again. Declined again. Got put on to a Advanced Fraud team who wanted to verify details from my credit history (read: mortgage application), and it still failed.
I’ve tried about 10 attempts over two days, £1400 total, and they now think I’ve hit some sort of transaction list for the day.
So I have to wait and try tomorrow.
Or what I ended up doing: add a new payment online with my bank (faster payment), approve the transaction, done.

Bonkers


(Pawel) #32

I have very similar issue with Lloyds + Apple pay :frowning:


(Jason Yau) #33

same problem with lloyds


(Evan Davis) #34

I’m finding Apple Pay payments £100 with TSB don’t go through and cause the app to crash. Under £100 with TSB goes through fine.

Nationwide transactions over £100 also work fine


(Tristan Thomas) #35

Hey @evan, what do you mean they cause the app to crash?


(Evan Davis) #36

The Apple Pay transaction seems to timeout and I’m kicked out of Mondo and back to the iPhone’s home screen. It could be an iOS 10 thing (still on beta 1 till I get home).

Only happens when attempting a £100 or more Apple Pay topup using a TSB card.


(Tristan Thomas) #37

That’s not good! What app version are you on?


(Evan Davis) #38

I’m on version 1.6.0 #250 from TestFlight


(Tristan Thomas) #39

OK great :slight_smile: That’ll be fixed in the 1.6 version that’s going through App Store approval right now :tada:


#41

Just want to echo this. Today I wanted to top up by £150. My Lloyds debit card is linked to Apple Pay. I got kicked out, back to the home screen twice. I managed to get it sorted by using the debit card section indtead.

iOS 10 Public Beta 3
Mondo 1.6.0 #250

With a bit of luck, it looks like it has already been fixed but thought I’d report it just incase :+1:t2: