App crashes when attempting to open an EA savings pot with Charter

Hi All,

Just sharing an issue that I have when attempting to open an easy access savings pot.

I manage to to select the provider (Charter); select name; input amount to be transferred; then the screen turns white, and the message “unfortunately monzo has stopped” appears, before the screen turns blac and returns me to my monzo app homescreen. There is an option to send a report.

I am on an old Moto E running android 6.0, and have a standard savings pot, which works fine. The monzo app is version 3.4.0. My wife did open a similar savings pot on her phone a few days ago, and I thought it would be just as easy for me!

I have contacted chat on my phone, and have uninstalled/reinstalled as advised, but this has not resolved the issue. Whilst awaiting their response, any help and/or suggestions would be appreciated

Thanks all.


Hey @wailiu,

Thanks for the report.

This has been reported in the past and it might actually be a bug with Google Chrome, could you check that you’re running the latest version of Chrome? If not, could you please update and try again?



1 Like

Thanks for the suggestion craigj.

Version is the latest one, tried again; same problem.

I can successfully open a standard pot, but not one that offers interest.



Dear All,

Problem now resolved. Thanks to craigj who initially suggested updating Google Chrome on my phone. Although this alone did not solve the problem, I ultimately updated the Google App as well. This solved the problem.