[Android] 'Sorry, there was a problem'

Hi. Since yesterday I’ve been getting this everytime I try to open the Monzo app:

It won’t let me view my balance, account details or even use the help/contact interface. The card is still working and notifications are still coming through. Everything was working fine on Saturday.

Device is an Oukitel K3 running Android 7

Out of curiosity, are you using an Adblocker or VPN service?
Also i’ll ask the questions that will inevitably come…
Have you tried reinstalled the app?
Are you using the newest version of the app?
Are you using the standard release or Beta?
Can you access internet normally on the device?
Have you recently installed a SSL certificate to your device?


Hi, thanks for answering. Standard version, but I’m going to try the Beta now to see if that helps, hadn’t thought of that. Internet is working otherwise just fine and all apps are on their latest up to date versions. No adblocker I’m aware of though I don’t tend to see many adverts anyway except on YouTube.

EDIT: Just tried the Beta. Same error. I guess I’ll reinstall the standard one and see how that goes


Hm. OK, that seems to have fixed it. Odd. But thanks!


Bit of an odd one, would’ve preferred to get to the root cause but at least you are up and running again.

1 Like

I had exact the same problem. Restarted my phone bit only after I reinstated the app it worked again.
Maybe it is a small bug. It started after the last update on 31 May.