[Android] Rogue transactions appearing in Search ๐Ÿ”๐Ÿ›

When i search for a transaction, whether by actual company name or notes/#tag. The search results i get are totally random and have no actual similarities to what im looking for!
Has anyone else experienced this? If so is it a bug or something wrong with my android app?

3 Likes

Android search is very basic. iOS users can filter and search by all sorts of criteria.

Iโ€™ve been experiencing this for the last few days on Android. I thought it was just me but:

  • Sometimes I search for a string that I know should bring up results - which arenโ€™t presented
  • Sometimes I get ghost results - transactions that donโ€™t match the search criteria.

Anyone else?

4 Likes

Yes, I was looking for HMRC stuff yesterday and not getting the results I expected. Tried a few other searches and all gave incorrect results - transactions missing which should be shown, other transactions shown which were unrelated.

Iโ€™m on Android.

Edit - screenshot showing HMRC search. 3/6 transactions on screen are HMRC, 1/6 for salary, 2/6 for pot movements.

4 Likes

Same :disappointed:

2 Likes

:rotating_light: Sending Bat Signal :rotating_light:

@AlanDoe @nexusmaniac

2 Likes

Which app version is everyone on? And has anyone tried reinstalling the app? :eyes:

Iโ€™ve just spent a few minutes trying to break my own searches but everything is working as expected here :sweat_smile:

Are there any searches which do work as expected? I wonder if itโ€™s only affecting certain customers or search terms :thinking:

1 Like

4.22.1 beta here. A bit more info which is very strange but could be useful.

If I search for hmrc, there are random transactions also shown the list of found โ€˜hmrcโ€™ transactions. I tapped on one of the non-HMRC to check what category it was and it wasnโ€™t โ€˜Incomeโ€™ like the HMRC ones. But then when I tapped on back arrow (top-left) to go back to the search list - the transaction I just viewed has gone from the list!

There are multiple non-HMRC transactions listed in the search results and tapping on them to view the transaction, then tapping on the back-arrow (top-left) clears the transaction from the search result list.

If I tap on a listed HMRC transaction to view, then tap on the back-arrow it does NOT clear from the list, which is the expected behaviour. But the random (non-HMRC) transactions behave differently.

EDIT: well, wellโ€ฆ practising what I preach, I did the uninstall, restart device, download/install the :monzo: app and login dance :bananadance: and lo-and-behold, search works. Searching for hmrc returns only hmrc transactions.

Thanks @nexusmaniac - youโ€™d fixed it (for me) by your second question :+1:

1 Like

Such a complete pain in the ar53 to have to keep doing this though. There is no other app on my phone which I have to uninstall and reinstall to solve this kind of problem.

3 Likes

โ€ฆ and then go and enable payments with friends, biometric unlock & biometric authenticate again. And change the Monzo app icon too.

3 Likes

Iโ€™m on 4.22.1. Reinstalling did it. But sad face at having to.

(Thanks for the reminder though!)

2 Likes

Iโ€™ve got the same issue. Iโ€™m searching for a very specific search term that I have in the description of all the transactions that I wanted to show up (the name of a tabletop game). Last two and a half months of transactions show up correctly, but then from December and before, only a couple of related transactions then random other unrelated transactions instead (that have no way of matching the search term).

Same issue

My employer, letโ€™s call them owlcorp, pays me by bank transfer from an account in that name, each month.

I searched owlcorp and noticed only the last 3 payments showed up, then after that several older payments for other, seemingly unrelated things - random pot transfers, purchases or bill payments.

So I then noticed that if I scroll back through my feed and find one of the older payments, and tap on it to open it, that payment (and that one only) is then added to the search results when I search owlcorp. So itโ€™s as if I need to click on each one in order for the app to index it. This is even though the other, random, payments showing up go back further in time than the newly showing owlcorp payment.

When I click โ€˜Number of paymentsโ€™ inside any owlcorp transaction, I see the same results as when I search owlcorp, so the issue applies equally to that. Worth noting that the actual number shown seems to be correct and doesnโ€™t change as the list does, but the list shows far fewer transactions.

For the random payments which are showing that are not owlcorp, if I tap one of these to open it, it then stops showing that result in the search results. Like it suddenly realises โ€œoh wait, this isnโ€™t owlcorp!!โ€

I also tried looking for a different search term, zooplus (a shop), and as far as I can tell those results are showing correctly - they go back much further, and only include relevant transactions. So it isnโ€™t affecting all search terms.

I have not uninstalled and reinstalled yet - since I have no urgent need for search, Iโ€™ll leave it for a week or so in case anyone wants me to โ€˜testโ€™ anything else.

Galaxy M31, Android 11 (One UI Core 3.1)
Monzo app version 4.22.1

After taking the below screenshot I clicked on Gousto payment at the bottom and it stopped showing in search results immediately. I assume this would happen for all the non-owlcorp payments.

PS this thread should probably be tagged as Bug Reports too right? someone already fixed this lol

1 Like

I cleared the cache/data and the error seems to have sorted itself out but not sure if this will crop up again once the cache has had chance to build itself backup again.

Thanks for all the detail here everyone! :hot_coral_heart:

Itโ€™s great to know that clearing cache or reinstalling the app is enough to get this working temporarily/permanently :crossed_fingers: I know itโ€™s not ideal but if thereโ€™s a workaround itโ€™s not quite as catastrophic.

But with that said, Iโ€™ve raised this with the Android team to see if they can dig into whatโ€™s going on here :eyes: Hopefully itโ€™s something straightforward to mend!

Iโ€™ll be back if there are any updates to give but donโ€™t worry if you donโ€™t hear from me for a while, it wonโ€™t get forgotten :blush:

9 Likes