✅ [Android/iOS] Unable to create repeating payment

Issue: I’ve recently renewed (and have on autorenew) my playstation plus subscription. I’d like to create a repeating (annual) card payment for summary to predict when it’s coming next. When I set the switch on for repeating payment I get the message “Sorry there was a problem. Please try again and contact us if it continues”

Details to reproduce: try create a repeating payment from a card transaction
OS: Android 9 (MIUI 10.2)
Device: Xiaomi Mi 9
App Version: 2.56.0 (on the new app design)


Could be because you’ve excluded it from Summary use? The two options may be incompatible.

I thought that and toggled that off - no joy

I just tried and it toggled on then toggled off itself

I can’t actually find summary to check though. I’m guessing it can’t add to summary as it’s disappeared

Can you create a repeating payment?

If so - I’ll contact COps. I wasn’t sure if it’s specific to me or if it’s an app-wide bug.

No. It seems to be a bug

You on the new nav? Possibly it’s to do with that and will be sorted in the next release. I’ll check the thread and see if it’s been mentioned on an update

1 Like

Can’t see it mentioned specifically but they are aware a few things are broken especially to do with summary and left to spend.

Perhaps post on that thread to see if it is linked?

Yeah I’m on the new nav.

I just toggled that off in labs to see if I can create a repeating payment and no joy.

I turned the new nav off and get the same problem :man_shrugging:

Replicated after turning off new navigation

Android and 2.56.0

not related to your bug but it was mentioned that u couldn’t find summary. I just found it by clicking my balance

1 Like

Tried that and it’s not doing anything

I’ve a little pie chart symbol up top right that takes me to summary

My spending bar came back. Pity, it’s red, can it go away again? :cold_sweat:

1 Like

Same issue for me on iOS, except there’s no error message. Tap the Repeating Payment toggle, choose ‘Create Subscription’ and the toggle automatically turns back off. I’ve never had the new interface - I’m on Monzo 2.54.1 #539.

1 Like

Just created an account to report the same issue: this has persisted across a reinstall of the app (iOS), and while I found it first in the current stable interface, it also replicated to the new one when I tried opting into that to see if it changed anything.

I’ve spoken to customer ops and they’re gonna flag it to the developers

Same issue on iOS but no error messages…


I’m using iOS beta 2.55, you - Android… I tried App Store version as well. So I don’t think this is app issue