✅ [Android/iOS] Round Up keeps turning off when a pot is edited

Anyone else notice the round up transactions toggle seems to unset itself ? The coin jar pots on my personal and my joint current accounts both had the toggle unset this morning and I had to switch them back on.

1 Like

Yes, mine too. I just checked it. Looks like it happened yesterday because none of my transactions got rounded up.

This happened me the other day also.

I put mine down to the fact i deleted a pot (not the one that had roundups enabled)

I didn’t do that, but I locked a pot…

It seems to happen each time the app is updated. I posted something similar in the Joint Pots thread.

1 Like

Issue happens when any pot is edited / unlocked, happened today when a pot was unlocked


Ahhh that’s would explain it. Crazy though but makes sense as two days in a row my round up has disabled and both days I’ve adjusted my pots. :see_no_evil:

Just spotted mine had been turned off as well. Not sure how long for :neutral_face:

Hi guys,

I have a weird issue where the round up feature on my pots seems to disable itself periodically. Anybody else have a similar issue? (and a fix). I’m on android and it’s a non interest pot


Yep, happens to me quite often on iOS right now.

It’s been happening to me every now and then I hope there’s a fix for it coming soon it seems to happen when you lock a pot oddly enough. Also I’m on iOS so seems to be an issue across both platforms.

Worked perfectly for me when I first got Monzo, only seems to be a recent thing? Roughly 2/3 weeks after they launched the interest pots

I’ve had it since locked pots were introduced

1 Like

This for me only happens when you lock or unlock a pot, the other day it happened when the locked pot unlocked as it reached the specified date.

If you do not create and lock a pot or the locked pot reaches the specified date the roundup feature disbales itself.

:wave:Hey everyone, just want to jump in quickly to say two things.

  1. This has now been fixed, you should be able to close or update any Pot without having roundup disabled on another Pot. The last bug fix went live last night :raised_hands:

  2. Just want to quickly explain how / why this happened. Just under a month ago we decided to clean up some of the code used to make round up work. We posted about this here. This bug you all helped identify was an unintended consequence of this internal cleanup.

Thanks so much for helping debug this and bearing with us while we fixed it. :pray: Do let me know if you continue to notice anything strange, though I anticipate you shouldn’t!



Thanks for the update - both the bug fix and the explanation as to what happened!

Ah, I wondered if the two were linked. Thanks for the background information.


Thanks for the quick fix and explanation :+1:t2::blush:

1 Like

Hi @constantijn is this being pushed into the next release?

As this bug is still happening for me as of today.

Same here!