[Android] Fingerprint payment Authentication

Fingerprint payment authentication not working

Details to reproduce:
I have been trying since yesterday to make a payment but I keep getting stuck with the Fingerprint authentication until I disabled it right now and the payment was processed with the pin authentication.

Android 10 latest os version

Samsung Galaxy S10 Plus

App Version:

Unable to provide

I take it you can unlock your phone with fingerprint though, yes?

Just eliminating any sensor pad issue.

I find sanitizing hands more often now plays havoc with my phone sensor pad.


Yeah the Fingerprint works perfectly, even for the log in into Monzo’s application. It’s just the authentication when making a payment that keeps going into a loop of requests for authentication.

I’ve had the same issue for a week or so. About 3 different payments the fingerprint auth vibrates like its worked fine and doesn’t error but stays on the same page and I’ve had to use SMS verification

Fingerprint auth works fine in all other apps including logging onto Monzo

This on a Pixel 2 originally on Android 10 but also having the same problem on Android 11

I’ve had the same issues since the start Tuesday.

Pixel 3, Android 11, Monzo app version 3.52.0

Fingerprint can be used to unlock monzo and in other apps fine (so not the scanner). But can’t authenticate payments with fingerprint. I get the vibrate to say the payment has gone through but no notification or change in the UI or deduction from my bank account. People I’ve tried to send payments to have told me that they haven’t receieved the money.

Have turned off the fingerprint authentication for payments and have reverted to pin and payments now work fine.

1 Like