All amounts reset to zero after latest Testflight install


(JoeO) #1

Hi -
Just installed the latest Monzo test flight version and all my transactions are showing 0.00 in the amount field. If I click on one then it actually fetches the real amount and this then gets displayed correctly in the spending home screen.

The totals all seem to be correct so I think this is just a display issue but it us quite disconcerting.

Test flight version is: 1.9.3 #300


(Alex Sherwood) #2

Just to let you know, this has been mentioned in the developer’s Slack channel (you should join :wink:) & the Monzo team are aware of it.

Switching tabs, getting a new transaction & force quitting then reloading the app also causes the figures to update.


(Rika Raybould) #3

Yup, just a display issue of some kind. We made the iOS team aware of it in the dev Slack about a minute after the build dropped. :thumbsup:

As a fix, simply pull down to refresh your feed or force relaunch the app. It only seems to affect the first time after installing so it shouldn’t reappear!


(JoeO) #4

Actually I tried all those things (refresh, force quit, switching tabs etc) before reporting the bug.

The only thing that seems to work for me is to go into each individual transaction, which I have now down up until the 20th Jan but everything before then is still stuck on zero.


(Alex Sherwood) #5

Lucky you! Fortunately they’ve figured this out already :slight_smile:


(James Nicholson) #6

Cheers for the report – as @alexs mentioned this was also reported in the Developer Slack. As a result, we’ve found and fixed the bug (presentation issue related to internal database migration), so expect an update on TestFlight later today.

Having power users like yourself on TestFlight to kick the tyres helps us ensure production releases are stable for everyone. Thanks again! :heart:


(Tom ) #7

Ah I’m late to the party. I screen grabbed it and everything - but haven’t had a chance to report it until now. It was a rather terrifying 10 seconds.

I’m not a developer - would it be of any use to join the slack community @alexs?


(Alex Sherwood) #8

It’s mostly tech / random topics chat, not a lot of super technical what’s “your favorite programming language & why?” discussion. But even if you only join for feedback after TF releases, the Monzo team can pick it up & discuss it straight away there…


(JoeO) #9

By the way - the latest ‘fix’ has not fixed it for me. All the zero amounts are still there even after a refresh and a force quit.


(James Nicholson) #10

Hi Joe! You’ll likely need to delete the app and re-install fresh from TestFlight, as the bad presentation data will have been cached by the app now. Apologies, I should have included this in the release notes!


(JoeO) #11

So if I delete the app Testflight will give me the option to install afresh?


(James Nicholson) #12

Yup, you can delete and re-install from TestFlight :slight_smile:

The only time it disappears is when that version is released to the App Store (in which case you can use the App Store version as that will be the latest release).


(JoeO) #13

Cool thanks James.
I’ll try it shortly and report back.


(JoeO) #14

All good now. Thanks again James.