2nd replacement card not arrived

2nd replacement card not arrived and I can’t request a 3rd as I get a failure message at the last step. How can I order a new card and should I be concerned that the first 2 never arrived?

Double check your address is correct, no don’t be worried as the card is not active

1 Like

Einstein definitely said something once about doing the same thing repeatedly and expecting a different result…

Your other two cards aren’t active so can’t be used. Check your address is right and contact support via the app, they’ll order you a new card.


Thanks both (Einsteinien sarcasm notwithstanding :roll_eyes:). The app let me order a third at the 10th attempt. Address is fine and hasn’t been changed since I was a beta user. Will see if Royal Mail deliver third time lucky!

1 Like

Are you getting your post though and when you do are the dates on your letters fairly recent?

I think if I were you, I’d be posting myself a letter to see whether it arrives. You may well find it’s just delayed at Royal Mail and repeatedly sending more cards doesn’t help it.

Other mail seems as fast as usual. I realised the cards weren’t active by the way. My concern was more whether Monzo’s processes were working ok (especially given the repeated error messages when trying to order). I test software for a living and the updated app seems a little flaky in other places to me. Can’t find the support/chat link in the app, otherwise I would have raised this via that route. Have they removed chat completely or just made it awkward to find?


Search contacting support in the help section.

Yup, tried that, but for the ‘replacement card’ options it just takes you in circles and ends either on a ‘order your new card’ page or an ‘activate your card’ one. It used to be much easier to activate chat from a link at the bottom of the help Home Screen :roll_eyes:

1 Like

Just select the ‘something else’ option then.

If you can find a route that ends in the live chat option, please post it here because I’ve tried dozens and they all end in a ‘self service’ section of the app. I’m a patient man, but they’ve clearly designed it to frustrate and infuriate :roll_eyes:

Help. Search for “contact” and press “contact us”

Just don’t select card replacements as that’s supposed to be self serve.

Still this old thing…

1 Like

I see I’m not alone in being confounded by their UI then?

That route just takes me to the ‘self help’ route I mentioned before. Maybe being on the latest iOS 17 public beta isn’t helping?

Pick an option and then pick something inside that option that gets you to a person

That’s basically saying I should play ‘guess the outcome’ by blindly picking random options, totally unrelated to my actual issue, in the hope one of them might take me to functionality that used to be 2 clicks away?

I have tried the above a few times by the way with no success. It shouldn’t be this needlessly difficult though

1 Like

It used to be two taps and support can’t cope.

I thought you’d managed to order the card anyway?

Given that my previous several attempts to order it ended with the error below, I’m not sure if I could trust the ‘success’ outcome at all (especially since the previous 2 success messages resulted in no card)

Try this…

1 Like

Perfect, thanks.

Hacking into a help page is a first (and I’ve been a software tester since the millennium bug :ant:)