Zilch - Free £15

Click the link and register.

It will give you 1500 points/£15 and then you can choose the retailer you wish to use. I used Amazon.

Add to basket on Amazon (or chosen place)
Add the Zilch virtual card
It will show the full total (in my case £17.96)
Use the Zilch card
My Monzo card was then charged £2.96

Easy.

This is my referal link for full transparency

edit

Link in the wiki

I think referrals on this forum are a no-no, unless they’re in the Wiki

2 Likes

Fixed!

1 Like

Also, what is it? Your description or the link doesn’t give it away

Basically another BNPL type thing but they also offer cash back by the looks of it.

I only used it to get free money and probably won’t bother again

1 Like

Thank you for this!

1 Like

Thanks for the spot! One thing it’s not letting me do is add a Monzo virtual card. It thinks it’s a credit card.

1 Like

My partner has had an absolute nightmare with this and is stuck in an ID verification loop and we can’t get hold of anyone to try and resolve it. He keeps being asked to prove ID, which he does - he then gets a follow up email asking for proof of residence but when he goes to try and submit this it only has options to provide passport/driving license (it is basically just the standard ID verif screen). So frustrating - it has been dragging on for 12 days now.

I’m in exactly the same boat. I did manage to chat to a human and they said my query will be prioritised. That was a week ago.

1 Like

I managed to sign up no problem. But as for claiming (or spending) the free £15, it’s been almost impossible.
Jump through all the hoops and it still takes the total from my underlying card.
No idea what I’m doing wrong :man_shrugging:

Did you use the virtual card on whichever site you used?

Didn’t work for me. It did the ‘active card check’ and then came up with an error. Tried a few times, and they all appear in my Monzo feed, but obviously didn’t pass for whatever reason.

As far as I know I did.
Maybe it’s just me doing something wrong.

I managed to get it to work but had the ID issue loop till I contacted customer services. I had to use my Lloyd’s card as it wouldn’t let me use my monzo card. Before I used it I had to select the merchant and activate the card in it. It worked for me.

1 Like

Update is there is no update. I hadn’t heard anything after ID query was escalated about a week ago. This morning the chat person said they’ve no idea how long it takes for an escalated query to be contacted. I shall be asking them to delete account and all my ID docs soon if I don’t hear anything further.

1 Like

I suspect this must have happened with a LOT of people. I also wonder if they got more people signing up than they expected and are hoping that people will just give up so they don’t have to fork out as much in rewards? Really frustrating though!

Yeh maybe you’re right. Annoying though that there’s no sign of it being sorted, and no acknowledgement there’s a problem. I’ve just got to wait :man_shrugging: