Unable to create shared tabs

Issue: Unable to create shared tab

Details to reproduce: Put a name to a shared tab, no special letters: “Xyz’s Gift” (without quotes, tried to drop the single apostrophe too), select few contacts (tried 1 to 4 contacts), then get a failure. Also tried resetting cache and force closing the application.

Update: also deleted and reinstalled.

OS: Android
Device: Samsung S23 Ultra
App Version: 5.19.0



I have the same issue (same steps to reproduce and the same error message).

I’ve tried contacting support but it’s a somewhat slow/clunky process going through the triage process (‘have you uninstalled the app’, ‘have you tried a different internet connection’) via the in-app chat that doesn’t notify me of new messages.

I’m on 5.19.0 of the Android app on a Pixel 5 on Android 13 with the latest Play and security updates.

I can share my Monzo account number with Monzo staff via DM if that helps.

Same for except the warning I get is ‘Still there? We lost you for a second. Try your connection and try again.’

Same problem here, I have tried different contacts, and clearing down the cache too. No success

Same issue here, Samsung Galaxy S23 Ultra also.

Been this way for a couple of weeks or so…


this has been going for weeks.

Same on Pixel 6

Same here - Also Samsung s23 Ultra interestingly! Although my girlfriend has the same on her samsung S22.

This appears to be fixed for me since 5.21.0 (Android, Pixel 4).