Trying to buy a new car and Monzo has frozen my account!

I recently sold my vehicle to wewantanycar.com everything went through got my money from them, all above board. I found a vehicle prior, and went to the dealership. It was part financed and part deposit £6000. Monzo froze my account and it’s been over 25hrs even though I provided them with evidence they asked for. I just keep getting the same message I just have to be patient? I understand that it’s a large payment but it’s just common sense? I got paid into your account from a car buying company and then I’ve tried to buy another car with that same money. What’s crazy is I didn’t have enough money in my other account to book a train ticket home fortunately it was enough for a hotel room. But it just beggars belief my own money held ransom by my bank, the irony! I know that checks sometimes need to be made but how long I’ve been waiting is unacceptable. I think I’ll be closing my account after this, which is a shame never had an issue before but I’m glad I didn’t completely switch over. My main bank would of had this sorted in under an hour!

Not much we can do here I’m afraid, solely users of the bank such as yourself.

It is a shortfall that does need fixing as many users report similar under fraud, however, the FOS and FCA don’t see them doing any wrong.

Raise a formal complaint to monzo.

2 Likes

Its been since Feb 20th or its been 20 hours?

You’re ripe for fraud at this point!

It shouldn’t take so long for them to unfreeze the accounts though.

4 Likes

This is the issue, not necessarily that they froze the transaction. It should be a same day/within hours to get sorted, not weeks and nothing.

8 Likes

Yeah typo it was over 25hrs in the end :neutral_face:

Yep! I have done :+1:t5: I know it sounds like I need some :cheese: with my :wine_glass:. But it was so frustrating being in abject limbo. I have worked for a high street bank specifically in the fraud dept and I have a degree in finance. Monzo if you’re reading any of this I’m happy to work together to improve this process because as it is…… it’s broken! :disappointed:

6 Likes