Targets bug


(JoeO) #1

Sorry to be reporting a bug so soon after the feature has been released but…

I was playing around with the feature and hit Done which saved an overall spend target of £800.
Subsequently I went through and actually set targets for category which actually came out as £710 but hitting Done still leaves me with a overall spend figure of £800.
I even tried adjusting the overall spend figure and hitting Done but that does not seem to work either.
Any way I can change this overall figure?

Cheers


( related to Monzo CEO, Investor in Monzo ) #2

if you adjust a category spend to spend more, eventually this adjusts the total spend upwards once you have used up the “spare” cash in total spend that hasn’t been allocated to one of your categories - is that the problem , or are you saying the total spend is fixed and cannot be changed


(Alex Sherwood) #3

I think I was talking about the same functionality here

but I’m assuming that the total hasn’t been designed to update, based on the total spend that’s allocated to the categories.

If you try increasing the target for one category so that it takes the total allocated to all categories to a figure that’s higher than the total, the total does increase so there is a link, it’s just that it only increases the total, it doesn’t decrease it.


( related to Monzo CEO, Investor in Monzo ) #4

and the total will only decrease manually to the actual total of all the categories added up - no more ( or should that be less :wink: ) , until you change a category entry - wow this is complicated to try and explain

edit

if your categories add up to £710 you should be able to adjust your overall monthly target total spend with the minus key to the left hand side down to £710 then press done which should then save it all to your spending table


(JoeO) #5

Actually no - what I’m referring to is different.
Basically it seems that once you have set an overall figure you cant change it. Or at least I haven’t been able to.
I accidentally set an overall figure of £800 and now, try as I might, I cant get it to accept anything else (even though changes made in the individual category targets seem to update and save correctly).


( related to Monzo CEO, Investor in Monzo ) #6

maybe try turning your phone on and off if the Total spend is stuck ?
edit

presumably disable targets at the bottom of the screen doesnt work for you either ?


(Ben) #7

@Trash Are you on the TestFlight build? If so, update to the App Store build and it should be fine.


(JoeO) #8

Tried that - no difference (but thank you for the suggestion anyway).

Anyone from Monzo listening??


( related to Monzo CEO, Investor in Monzo ) #9

we tried :slight_smile: either send an email to help@monzo.com or use the in app chat if you have availability to it or tweet to @monzo


(JoeO) #10

Thanks for trying.

I don’t want to tie-up precious resources on what is after all a straight forward bug. So I will wait for someone (@hugo?) to catch up with the threads and see what is what.

The basic problem is that once an overall target has been set there does not seem to be any way of changing it - it gets stuck on the original value.


(Tristan Thomas) #11

Hey @Trash, so you’ve tried to change the Overall Target and hit Save, and it’s still showing your old one?


(JoeO) #12

Yes indeed, exactly this!

Well actually I hit ‘Done’ because there is no Save button that I can see.


(Tristan Thomas) #13

OK. What happens if you disable all the targets and start again?


(JoeO) #14

Hi @tristan

Selecting Disable all targets and then hitting Done doesn’t do anything i.e. I am left with all targets still enabled including the overall spending target.

Any other suggestions?


(Tristan Thomas) #15

Can you delete and reinstall? If this doesn’t work, we’re done for!


(JoeO) #16

@tristan

Actually I already decided to do that and it seemed to work.
The Target details were still preserved BUT at least after the reinstall I was able to disable all targets and start over again.

I was on the TF version - I presume that I will be able to install the next TF version when one becomes available?


(Ben) #17

Yes, you will :smiley:


#18

I noticed that if I set a target for the General category for example, and then pay a friend using Monzo and categorize it as General, it does not reflect in my targets at all.
Not sure if this is a bug or expected ?


#19

I guess it was a bug after all, when I changed the category manualy again it changed the targets.


(Ben Green) #20

Just discovered another one, although not detrimental just seems odd.

I made one transaction in the entertainment category, the bar went down and went from grey to orange. I then got a refund and the bar went all the way back up but went green instead of grey?