Something's gone wrong error message

Issue: I regularly get a “Something’s gone wrong, please try again in a few minutes” error

Details to reproduce:
The issue occurs when I first use the Monzo app in the morning. I’ve tried restarting my device. I’ve tried deleting and reinstalling. I’ve tried the most recent TestFlight version. I still get the error message pretty much everyday.

Device: iPhone 13 Pro
App Version: 4.35.0 (also occurs on the most recent TestFlight version)



That normally means there’s a network issue, are you using the app over Wi-Fi or mobile date when you get this messge

Hey @_Tom thanks for looking into this - I’m experiencing the issue over both WiFi and cellular. I’ve looked at the network traffic the app generates on start and I can see it successfully getting to, etc and all the connections seem to be made successfully. I guess I could put the traffic through WireShark but I’m not sure what api call is causing the failure so I’d be shooting in the dark :slight_smile:

Let me know if I can provide any more useful diagnostic information

1 Like

Is the message persistent throughout use or does it go away at all?

Are you still able to use the app and it’s features?

Just to note that I also get this quite often on iOS currently. App store version.

1 Like

The error message goes away after 20 seconds or so, then the app behaves as expect.

I’m having a similar problem on iOS - I can’t make a bank transfer from either my iPhone 12 (Wi-Fi) or my iPad (Wi-Fi). I get to the stage where I enter my card pin and the error message comes up - the same on both devices

i get the somethings gone wrong msg from the on startup. cant access any of the app.
Im on Huawei p40 pro

1 Like

I get this intermittently too, have to force quit the app for the error to go away and for the app to show the latest transactions. Been happening for a while. I never have any Wi-Fi/mobile data issues when it occurs.

iPhone 12 Pro
Monzo 4.39.0
iOS 15.5

I have this issue too and it’s a serious problem.
Im abroad and have internet connection with ever other app accept Monzo.
I think I’ve diagnosed the problem with it being my IP address. I connected to the internet via a hotspot from another phone and it fixed the issue immediately.
Frustrating, how can I find a proper fix to this, I can’t keep having to find different internet connections?!

Same problem!!

I’ve experienced this issue for as long as I can remember on iOS. Currently on 5.1.0 but have seen this on loads of versions. Doesn’t matter whether I’m on Wi-Fi or 4G. Usually see it at least every few days. Using Face ID for authentication. I ‘fix’ it by closing the app and re-opening which always sorts but it’s a bit frustrating. My other half doesn’t seem to have the issue.

1 Like

This is still very much a thing. iPhone 14 Pro Max running iOS 16.4.1

It happens very often whether on Wi-Fi or cellular and I fix it by force quitting the app and re-launching it.

Is this still being looked at?