Problems adding Premium card to Apple Watch

After I installed WatchOS 9 on my Apple Watch series 6, its Apple Pay stopped working. Eventually I worked out that there were no cards on it - the upgrade had wiped them all.

Now I cannot add my Premium card back onto the watch - it’s working fine on my iPhone 12, but I’ve had various errors in adding it to the watch. First it added it ok, told me in app that it was verified, but it didn’t work. Then it only offered me a phone number for verification, but the long recorded message said it wasn’t for Apple Pay issues. I’m a bit stuck - any ideas?

I’ve reset and restored the watch from backup, made no difference.

Have you deleted it from your phone and started from scratch?

I had an error come up on my new Apple Watch for Monzo too actually, but I just left it and forgot to retry. Will have a try now and see if there are any issues.

This Thread might help

1 Like

Just be aware that signing out of iCloud will remove ALL your cards from your wallet and can really mess up some other iCloudy things, too. Last time I did this it was a world of pain.

I had a similar issue with my Plus card the other day and solved it by deleting it from my iPhone Wallet then adding the card to the watch first, then the iPhone, both using the in-app option to add to Apple Pay.

1 Like

I found that i had an error trying to add my new card this morning , i have since sorted it by adding the card through the watch app as if its not already in the wallet app on my phone. Trying to add it from the “mirror “ of my iPhone was throwing the error.
Hope this helps.

Go to the watch app , wallet , scan card or manually type in the card details (don’t select previous added) and follow through the steps.

Thank you thank you thank you. That worked, once I got past the ridiculous “would you like a loan” splash screen in the app!