PayPal portable card transaction machine Monzo card declined

Hey.

Had to call out a plumber today and he accepted payment using one of those PayPal card machines illustrated below

image

I inserted my Monzo Plus card and entered my PIN but the payment was declined. No notification on the Monzo app that I usually get.

Had to use my Amex card which worked alright.

No problems with my Monzo account though as I had the right balance available and I’ve just used my Apple Pay at the corner shop afterwards which no issues.

Is this just a one-off?

I used to have one of these and it worked fine with Monzo cards as I tested it with my own card when I got it.

I no longer have the reader (it broke randomly) so I cannot test it out. Interesting if PayPal have changed how they process since I tried.

There’s been a few other posts elsewhere about monzo plus cards and the suggestion that as the card numbers are a different sequence (don’t recall the technical term) has caused the problem as they’re not in the range the machine is looking for.

Of course I could be talking utter nonsense, best to raise it on chat through app

From what I’ve seen elsewhere I think the physical cards are in the same range with the virtual ones being different.

3 Likes

There ya go I’m talking balls :rofl:

2 Likes

This would seem to indicate it is a problem between the card and the card reader, as it hasn’t even got as far as sending the transaction to Monzo to verify it.

Try using chip-and-PIN next time at the corner shop, to rule out a broken/damaged chip in the card?

1 Like

I’ve used it in Tesco Self-Checkout’s Chip & PIN machine with no issues.

Used one of those card readers just now and it worked first time with my Monzo Plus card

Chances are they haven’t done the firmware updates on the reader and that’s why it didn’t recognise your card. You should advise them that iZettle has lower fees (and no fees on August) and ask for a discount for improving their business :joy:

I wonder if the PayPal readers have an offline mode, for when there is no signal, this would explain no app notification (as the card declined the offline transaction, not Monzos servers declining)

Perhaps. This payment was literally made in my bathroom.