✅ [iOS / Monzo.me] Monzo.me domain missing apple-app-site-association file

This may be a little technical, but bear with me lol
The monzo.me domain is missing the apple-app-site-association file preventing iOS devices from recognising monzo.me links as a link to open in the Monzo app. I’m assuming this file was once there, therefore devices have cached this page. However, my device must have cleared this cache (not sure how, or what I did?)

(https://monzo.me/apple-app-site-association / https://monzo.me/.well-known/apple-app-site-association)

The monzo.com domain does have this page (https://monzo.com/apple-app-site-association) and iOS does recognise to open these links in the Monzo app. See screenshots below.

I have wiped my phone and done a fresh install of iOS and tried carrying out the same steps, but the monzo.me link still doesn’t open the app.

Details to reproduce:
Needs to be on a new device that has never accessed monzo.me recently.
Visit https://monzo.com/app this should trigger the Monzo app to open.
Visit https://monzo.me/“username” this page now only opens in Safari, doesn’t prompt to open the app or show the banner at the top of the page to click through to the Monzo app.
OS: iOS 12.3.1
Device: iPhone X
App Version: 2.54.1 #539


Thanks for the report, we’re taking a look.


Thank you, my report was based on this document by Apple: https://developer.apple.com/library/archive/documentation/General/Conceptual/AppSearch/UniversalLinks.html

1 Like

I’ve deployed a new version to restore the missing .well-known files. Thanks again for letting us know.


Thanks for the quick resolution. I can confirm the link now opens the Monzo app! :slight_smile:


Thanks Dan

Any insight you are able to provide into how they went missing and how it can be ensured that this does not happen again?

The .well-known files are a special case for the app, because they are configured per-environment and have to have special arrangements made in the build script and server. I made a mistake in the build script such that the configured files were never linked through to the right directory to be served from. I’ve now written a browser test to make sure they’re served properly.


Thanks Dan