Google pay setup failure

After changing phone a month ago, I’ve been having a nightmare trying to re-setup google pay on my phone.

Every time I try to add my monzo card to the wallet, the last step of contacting the bank always returns a problem and asks for me to contact the issuer (not to verify I approve the card). I spoke to monzo after trying again a few days later and they could see, I assume all, the requests from google pay to add the card, but after escalating the problem they told me to contact google.

So that’s what I did, I contacted google and they said that my account is in “good health” and explained that the card I was trying to add wasn’t “tokneised” which is why each attempt is failing. The resolution they provided was to contact the issuer again as ask them specifically to tokenise the said card.

So I took this information back to mono and after being passed to another, I assume department, the response I’ve got is that they can’t add the card and can’t provide anymore information to what or why it isn’t working, which also includes if the card has been “tokenised” like Google requested.

I appreciate that Google might be throwing glitter in my face but I’m now left NFC-less with no clear path to resolve the issue and I would assume that google pay doesn’t play a huge part in the authentication and approval of adding a card, which would lead to either google sending a bad request to monzo or monzo rejecting the request.

*i’ve tried using both the app and physical card for setup, both return the same problem
*ive fully deleted the card from my last phone
*i can add other issuers cards to Google pay
*all of my contact infomation on google pay matches that of monzo

Has anyone encountered this issue or know of a way to resolve it?

Using a browser, preferably on a laptop/desktop, can you see the card in your account (in payment methods) and if so, are the details correct there?

While I’ve not experienced any issues with setting up GPay (and adding Monzo cards) on phones recently, there does seem to be a widespread issue in the area of adding cards without a solution:

The card exists as a payment method for Google services but the same issue occurs when I try to setup the card for contactless - I tried the steps in the link you included first too

I did notice that google sent a active card check when I tried to setup the contactless this time but it still resulted in the same problem

When I changed phone I had to contact Monzo in order to get Google Pay working, so might be I had the same issue you are having.

The Monzo COp who sorted it for me said they’d reset the card in Monzo, and that fixed the issue. I’ll see if I still have the chat history…

ETA: Here’s what they said “I’ve removed an old Google Pay setup on our end. Do you mind trying again? Hopefully it should now work.”

So perhaps the magic words would be to ask the COp to remove any existing Google Pay setup on your account, as it might be that there being an existing setup is what’s stopping a new setup from being created.


It looks as though that might be the right path as there are 6 google pay setups on my account.

It sounds as though each request is registering as a setup but not actually being approved and I can only assume there is an upper limit of active setups, even 6 sounds too high :smile:

They’ve sent it back to a specialist and ill update of there’s a reaolution.

I can’t help but feel the support where incredibly resilient to resolving the issue, sadly.


I get the impression that COps maybe have less room to operate outside of scripted responses than they used to (or maybe you’ve got a new/relatively inexperienced COp picking up your query). Hopefully the specialist will be able to help you and you don’t have to wait too long for them.

1 Like

I think it’s more down to what Nick mentioned. The support process is probably quite scripted and regimented so id imagine trying new ideas discouraged.

I’d say a lot of companies struggle when it comes to unusual technical support queries which this probably falls under :smile:

1 Like


I’ve been advised there is nothing they can do and the best bet is that just fixes itself.

I can’t help but feel as though the 6 active google pay setups are playing a part in the issue but they’re refusing to delete them as it’s not something they normally do. If anyone else has this issue that’s probably what id push for but play your cards cautiously as the only response I get now is there’s nothing we can do for any query slightly related to mobile payments.

It’s looking like I’ll have to move back over to another bank which is a bit of a bummer

1 Like

I think you’re almost certainly correct, and they’ve made the decision that it’s just too much effort to sort it out. I’ve had varied experiences with fintechs on this, and some of them you just need to walk away from.


I had same issue with HSBC, but they sorted this problem over the phone.

Maybe try to contact google instead ?