Failing to grant developer access

Having trouble granting developer access to my account. Failing when I am trying to grant developer access from the Monzo developer portal The link I receive says it fails authorisation. However it triggers a notification in the app to grant the access, however once signing in there nothing changes and I still don’t have access.

Long shot but is it possible you have anti virus software for example that visits the links in the emails you receives.

I know I cant change my password for a service at work as my employer does something along these lines.

I’m no expert on this but I recall something similar when someone only had a business account, not a personal account, so something wouldn’t connect as it should until they had a personal account.

Do you have both?

1 Like


I’ve tried using different devices, disabling and enabling vpns, WiFi and data. The only difference I spotted was on pc the error from the link mentioned state mismatch where as on mobile it was an authorisation error message.

Both still resulted in a notification in app to approve, but once again I still could not access after entering my pin.

I also only have a personal account.

Cheers both!

Inspect element, click console – does it report failures?

Yep, got Content Security Policy: The page's settings blocked the loading of a resource at inline ("script-src")

Decided to copy the link and paste into a browser the next time rather than allowing it to open itself and this worked. Presumably the built in browser on my mobile and default browser on pc were causing issues, compared to where I requested it from.