Oauth Clients not accessible in 'Monzo for Developers'

when attempting to access my Oauth clients at Monzo for Developers there are no clients visible.

Not only are they not visible, but the clients i have been using are no longer working. I also cannot create new clients (this fails silently).

Is something broken, or has this feature been removed?

1 Like

Is this for a business or personal account?

I believe it won’t work for business ones.

Like Carl said below, it’s when you have a business account but no personal account in your name there’s issues, if you do have a personal one it’s probably another issue.

1 Like

Another forum member was having difficulties with the API, and once he opened and linked his Monzo current account everything seemed to have worked.

I may be corrected though.

1 Like

turns out there were two issues. the first is as @Carlo1460 described - if you don’t authorise through the app it will silently fail to display or add new OAuth clients.

Secondly, my refresh token had been revoked, and any API calls using this token are returning a 500 (internal server) error, instead of a 401. Probably an unhandled exception bubbling up from somewhere.

authorising through the app and generating a new refresh token solved it for me.

I guess it might be more fair to call this bad UX, than anything actually broken. I’ve reported the misleading http error code from the API to support

1 Like