Difficulties paying TFL with Monzo (and other cards) with Apple Pay on Apple Watch

(Justin) #1

Hi

I’ve been using Apple Pay on my Apple Watch since the start of 2018 to tap into Transport for London. It worked fine and reliably on my original Apple Watch.

However, since upgrading to a Series 4, tapping in fails around 70% of the time, and I have to try again (often with impatient queues behind me). The watch actually shows that it was successful in initiating the process, but the TFL terminal beeps in error, and the only way forward is to double-click the button on the watch to initiate a new payment.

I finally called Apple support yesterday, and their initial theory is that this relates to Monzo rather than the Apple Watch or the terminal. When I tried to tap in this morning with Apple Pay using my Amex card instead, it went through without any issues.

Has anyone else come across this issue? I’d love to hear from other Apple Watch series 4 users paying via Apple Pay with their Monzo card.

1 Like
(Sarcasm is the finest form of wit.) #2

Had zero issues. I Monzo on Apple Pay on my Series 4 watch flawlessly for the last two months (as long as I’ve had a Monzo account). Used it in all kinds of stores. Never for TFL.

Not sure that helps.

2 Likes
#3

If the AMEX card works without issue, it suggests that the NFC chip for Pay is working correctly.

That said, it’s unlikely to be Monzo themselves that are causing the friction between your watch and the reader. All the NFC chip does is read data from the reader and replies by returning the information from the card.

More likely to be the angle that you’re catching the reader with.

I would recommend removing, and re-adding the Monzo card as a starting point. If that doesn’t solve the issue, restore the Watch.

1 Like
(Justin) #4

Thank you, both. That’s helpful. I think the more feedback we can get, the easier it’ll be to identify the root cause.

Apple told me that since the watch is displaying a tickmark after the attempted tap in, the watch has done what it needs to do, so the issue must be downstream from there. That would suggest either TFL or Monzo - or somewhere in between.

Interestingly, I did find further feedback on Macrumours about issues with Apple Pay on the Series 4, though none stated the bank card they were using: https://forums.macrumors.com/threads/anyone-else-having-issues-with-series-4-on-london-underground.2143363/

1 Like
(Rich Cousins) #5

Hey there,

Comforting to hear I’m not the only one. I’m having the exact same issues myself.
New watch series 4 using Monzo on TfL.
Works fine on all other stores just TfL it’s super hit and miss when it works.

Would love to be able to fix this. I wonder if it’s an issue with TfL or Monzo, as like someone suggested above, the chip seems to be working?

2 Likes
(Justin) #6

Hi @Richcousins, glad to hear from you (though sorry you’re also having issues).

I raised a call with Apple a couple of months ago, and they suggested I try switching to another card, so I began using my BA Amex card instead. Initially, no problems at all, but eventually, I started getting the same issue around 30% of the time.

My call with Apple is still open, so I’ll go back to them and indicate that this doesn’t seem to be a problem that’s restricted to Monzo cards.

Here’s a factor I believe may have a bearing on the issue:

  1. The way a Monzo card transaction works is different to some other cards. I believe that every time you make a payment (or TFL tap-in), a call is placed back to Monzo to authorise or decline the transaction. This is how when you freeze your Monzo card, it stops 100% of transasctions. However, it would mean that if the connection back to Monzo couldn’t be made, the transaction couldn’t be authorised.

  2. Conversely, some other cards work differently. When you make a low-value transaction with, for example, a Lloyds Bank Debit card, this does not necessarily result in a connection being made back to Lloyds. Some transactions happen offline - and this is why Lloyds tell their customers that freezing their card doesn’t necessarily stop all transactions.

This might explain why transactions on some non-Monzo cards might be more likely to go through. However, it doesn’t explain why the issue we’re facing seems specific to the Series 4 Apple Watch. Another possible cause could be if Apple decided to save battery on the Series 4 by using less power for each contactless payment. However, that’s pure speculation on my part.

Will do some more digging. However, do please share anything you’re able to learn too!

(Sarcasm is the finest form of wit.) #7

“I started getting the same issue around 30% of the time.” so it’s not a Monzo issue if it’s started reoccuring?

And have you raised anything with TFL?

Given the massive number of transactions that must go through their systems, it does seem that they are the central point of failure here?

1 TFL system
X number of banks and only for people using contactless (removes number of people using Oyster etc although that’s still a ‘tap’…).

1 Like
(Justin) #9

That appears to be the case, though the issue with Amex doesn’t seem quite as systematic as it did with Monzo. It’s possible that the two issues have a different cause. Either way, worth continuing to dig

(Tom ) #10

Hi Justin. Same issue here - I just stopped using the watch. I’ll try again today and see if I get an error and I’ll actually note the error number on the gate.

1 Like
(Tom ) #11

Code is:

“SEEK ASSISTANCE
USE ONE CARD 71”

Usually works on second or third attempt. Fun in rush hour.

Edit: Apple Watch Series 4

edited to improve TfL messaging

1 Like
(Caspar) #12

Someone on Twitter had the same error using a watch and was asked to get in touch with the contactless team.

Seems odd, why would it detect multiple cards when using a device.

4 Likes
(Sarcasm is the finest form of wit.) #13

HAS to be a TFL issue only. And I call a system that can’t cope rather than loads of people double carrying cards… (heard it here first! :joy:)

(Rika) #14

Not entirely true as far as we’re aware. It’s a regular Debit Mastercard built to the modern standards. The only difference is online/offline preference which I’ll explain a little below. :slightly_smiling_face:

This happens shortly after you have walked through the gate (or been declined for a blacklisted card), not while you’re at the gate. It would take even longer if TfL did that. :scream:

Freezing your card only stops online authorisations, it is still possible to travel on TfL (at least for one journey if it’s your first journey of the day) and make offline payments. It is not possible to block all transactions when frozen while still allowing our card to work in places that use offline terminals (extremely rare in the UK but can be found in busses outside of London and toll booths).

This is because Lloyds cards are still offline preferring while Monzo cards (and practically all modern debit cards) are online preferring. However, this is totally irrelevant to Apple Pay as all Apple Pay cards are online preferring and irrelevant to TfL as they use a completely different method. :slightly_smiling_face:

I should stress that the physical cards are preferring online or offline, they should always work unless a terminal is extremely badly misconfigured or if you have exceeded your offline limits.


To answer the original question though, after some investigation over the last couple of months, this is an issue between the TfL readers and the Apple Watch. Specifically, if you present your Watch to the gate too soon after selecting a card and/or pull it away too quickly, this error code can occur.

71 and 94 are practically interchangeable when dealing with Apple Pay and our best guess at this stage is that somewhere, the reader is initialising with the Watch and failing before the payment application on the Secure Element is selected and has responded. This seems to jam the Watch until you back out and re-arm Apple Pay.

It’s not an issue exclusive to Monzo but is something we’re tracking and trying to investigate. It seems exclusive to the Apple Watch Series 3 and 4. It does not occur on any other devices we’ve seen.

19 Likes
(Sarcasm is the finest form of wit.) #15

As always, thanks for sharing! (this doesn’t impact me but it’s still great and interesting!)

1 Like
#16

Ah, thanks. I thought it was just me.

I had to move to using Apple Pay on my phone rather than my watch with TfL, the watch was just too temperamental.

Liam

(Justin) #17

Hi @Rika , thank you very much for the detailed clarification - and apologies if my earlier post appeared to present as fact what I only believed to be correct.

I find it very interesting to learn more about how these types of payments work (in fact, it was a very early post of Tom’s in 2015 about how card payments work that initially compelled me to bookmark Monzo’s website and come back time and again to learn more - and eventually become one of the early Alphas!)

For me the most dramatic manifestation of the issue was when I switched from my original Apple Watch to a Series 4, since I’d never had a problem until then with any card - and this ties in with the reply you’ve given.

Thanks again :bouquet:, and do please keep us in the loop with any progress!

EDIT: sorry, that reply was intended for @Rika

5 Likes
(Rika) #18

No worries, most knowledge of card payments out there is either highly American or fairly old. The details of new things are typically under NDA but I’m happy to talk about what happens at a high level. :slightly_smiling_face:

5 Likes
#19

Your posts about card payments are always so interesting! I never thought I would enjoy learning about these things, but always love reading your posts! :blush:

10 Likes
(Tom ) #20

Never again after today’s experience. Is rather queue up and pay cash :see_no_evil:

(Adam) #21

Slightly misleading as when you freeze the card, your ApplePay card is also blocked and therefore can’t be used.