Card transactions not going through?

Hello - I’m in central London with full 4G.
My card transactions aren’t processing - I’m trying to buy something from TK Maxx.
The chat on the app isn’t work.
Can anyone give me good next steps to take to solve this please?
Thank you!

When you say they’re not processing, do you mean you’re not getting notifications, or your card isn’t working?

Fair point - so the retailer sent me back to the app for that authentication bit where you put your pin in to authorise the transaction. It’s stuck on that bit, won’t go past it. It just sort of times out and says “we couldn’t process your transaction at this time?”

Ah. I thought you were in a shop.

Assuming you have sufficient funds, the only thing I can suggest would be to either force close the app and try again, or delete and reinstall.

If you can supply your phone model, OS, and app version, someone more clever than me might have a better suggestion.

Good luck.


And are you opening up the app to authenticate?

If so, what happens there?

Sometimes it doesn’t always authenticate via app too, sometimes its a code that’s sent by SMS, make sure you haven’t got any texts from Monzo.

1 Like

Thanks! This solved it for me. I re-installed the app and it all just came back to life.


I had the same thing just happen to me for a Trainline Authentication - scanned through Face ID and just wouldn’t move on from the “Insert your PIN” - even when I did it just closed down.

Was able to brute force it through Trainline (I clicked “I have Authorised this Transaction”) - I’ve left a note on Chat about it, maybe something that happened yesterday is having a residual effect.

Maybe. I’ve just completed a 3DS transaction, and it worked fine (once I’d realised that the merchant still had my old card details and updated my card with them :man_facepalming:)