Cannot add Payee Photo

Issue: I have successfully created payees, however on attempting to add their photograph from Google Photos or the System Gallery, I select the photo, however, it does not

Details to reproduce:

  1. Open Payments Tab
  2. Select “See Payees”
  3. Select a payee
  4. Select “Edit”
  5. Select “Edit photo”
  6. Select “Choose from library” (see screenshot)
  7. Select a photo from Google Photos or System Gallery
  8. After being returned to the Monzo app, no photo is selected

OS: Android 12 (MIUI 13)
Device: Xiaomi Redmi 9
App Version: 5.37.0

Screenshots:

Hi @edapm & welcome :wave:

I’ve just tried following your exact steps and a photo from Google photos is saved OK against the payee.

I’m on Android 13,:monzo: app v5.37.0 - but a Pixel 5 phone.

Try the reset-dance :bananadance: : uninstall the Monzo app, restart your device (important), download+install the Monzo app, login to the Monzo app - retry to see if the issue is resolved or not. This clears 99% of ‘strange’ issues.

If it remains, it may be linked to permissions or even a weird OS-related issue.

1 Like

Same for me on a Galaxy S21 phone, same app and android version. Works for both gallery and Google Photos with no issues.

1 Like

Hi both, thanks for the help. Tried the reset dance :bananadance:, didn’t seem to do anything. Also messed around with app settings, but no change. It is probably a MIUI/Xiaomi issue, I’ve had issues with other apps before that only seem to occur on Xiaomi phones and work fine on everything else.

Wait is this also possible on the iOS app?

Not sure, anyone with an iPhone available to test if an ‘external’ gallery (or Google photos) image can be saved against a Payee?

Just had a look and it doesn’t give me the option to add a picture for any of my payees…

Payee Picture Playoff, full-time score:

Android 1 : 0 iOS

#platformparitydiff

Do we need to feature request this for iOS then? :thinking:

There’s this:

But iOS implementation and the payee photo appearing on the feed are both needed to mark it as done.

It’s annoying can’t do on my iPhone but have pics where managed to do it on android.